PDA

View Full Version : '94 5-speed hesitation



HSKR
01-25-2005, 12:50 AM
Been doing this for a while, but just decided to ask about it. If I easily roll into boost, the engine revs smoothly, despite not feeling as strong as I think it should under boost, but if I punch the trottle, and the boost guage sweeps from vacume into boost, the car jerks a couple times like it's hesitating, then continues on, but once again not feeling as strong as it should for running at 10+lbs of boost. It does this in every gear and at any speed. The exhaust is stock manifolds with Wynn's downpipes. No cats, brand new O2's, glasspack for resonator, then stock pipes to the 2"in/out Dual spintech mufflers in stock location. Onlything on top of motor that has been changed is the Ebay special Focus intake tube and MAF reloacted to right in front of TB(helps with clearane for the intake tube) Have Taylor 8mm Spiro Pro wires, and NGK Iridium plugs with about 10K miles on them. I run the crappy Cali 91 octane gas. Have the EGR unhooked. Has had head gaskets replaced, and new solid rubber motor mounts installed in last two years. Radiator leaks and is getting replaced as soon as the new radiator comes in.(plastic top on old radiator is cracked) I've asked for help in the SoCal area before for anyone to meet up and tell me what they think about the car. Only a couple have replied and they couldn't drive a manual tranny to take it for a test drive. The car has not performed like it should since I've owned it. At least not in my opinion. When I first bouht it, I contributed it to the bad motor mounts, and possbly blown head gskets. Since i have replaced both, it only slightly got better.

discipled1
01-25-2005, 01:57 AM
Just guessing, but it could be that the sampling rate of the MAF sensor is such that it can't provide information fast enough for the engine control because of its location being so close to the TB. Another possibility is that upon sudden OT, insead of the MAF sensor reading the passage of air, it is reading the low pressure at the intrance to the TB that is created when the vacuum on the back side of the buterfly infulences the air directly on the front side of the buterfly. My thinking is that there is a transition range from the front of the TB's inlet to its outlet. The farther away from the inlet of the TB, the lessor this effect, until it becomes equal (vacumm = flow). This is most likely about where the original location of the MAF sensor was located (along with accounting for the sensors ability to sample and respond to the engine control. There's also the issue of air turbulence so close to the buterfly in the TB.

The only thing that I can think of that would allow a MAF sensor and a TB to be directly connected, is to change the buterfly out, and replace it with a "stargate shield" (SG1) like opening and closing devise. In this vain, you would have a MAFTB. Okay, kinda out there, but fun to think about.

MikeKanterakis
01-26-2005, 06:40 PM
heh heh heh, I'll drive your car. :D Not sure, but I should be in O'side later this week. If you wanna meet up, give me a call on my cell 818-292-0352.

discipled1
01-27-2005, 12:14 AM
It's possible you are experiencing a lean condition upon acceleration.