PDA

View Full Version : DragSource Barbeque



New5ohKitty
03-15-2005, 06:45 PM
Allright you blower happy freaks.... DragSource is having a barbeque. It's going to be on the 9th of April, In Des Moines. Just a .5 block south of Hickman on 48th. There is a HUGE friggin parking lot right across the street from this guys house. DragSource would like to extend an invitation to all auto enthusiasts (and those with manuals too...:)). If you guys have any questions, feel free to post them or ask me, and I will get you an answer. I'll post a link to the actual thread on Dragsource later. This is an open party, so all ages & all cars are welcome. But don't come hating on imports. Just enjoy the time.

forcfed93
03-16-2005, 11:16 PM
Allright you blower happy freaks.... DragSource is having a barbeque. It's going to be on the 9th of April, In Des Moines. Just a .5 block south of Hickman on 48th. There is a HUGE friggin parking lot right across the street from this guys house. DragSource would like to extend an invitation to all auto enthusiasts (and those with manuals too...:)). If you guys have any questions, feel free to post them or ask me, and I will get you an answer. I'll post a link to the actual thread on Dragsource later. This is an open party, so all ages & all cars are welcome. But don't come hating on imports. Just enjoy the time.

I could be there! Any other info on it?

supercharged95
03-17-2005, 12:19 AM
here ya go mike:

clicky (http://www.dragsource.com/board/viewtopic.php?t=3865)

here's a webiste based out of cedar rapids for you cr guys....

CRunderground.com (http://www.crunderground.com/)

Thomas
03-19-2005, 09:21 PM
I might be able to come, I'd really like to. Hey, how's the kitty running by the way?
-Thomas

New5ohKitty
03-21-2005, 03:10 PM
My pretty kitty is running quite nicely, besides a few quirks. The heat guage never gets up to normal, just stays on the low end, not quite to the N. But it isn't overheating, or using any antifreeze.
The other quirk is that since the battery is so old, and the terminals corroded, plus I think one of the posts is damaged inside the actual battery case, occassionally you have to fiddle with the connectors to get it to start. So I've got a new battery, just waiting for some spare time to swap it out. Oh, and the speedo/tach occassionally quit working, then come back on after awhile. They just drop to 0, and the low fuel light comes on. Then, after awhile (variable time elapsed), they come right back on. and work fine. Eh...oh well.

I do think I need that J-mod done on the tranny though. It drives fine, I just want more feeling to it.

What kind of parts do you have just lying around? I remember you saying something about having some extra stuff. hmmm...How much for you to do the J-mod? With parts?

As far as details go, as soon as I can get back on DSource, I'll see if there is any additional info. I'll get the exact address ASAP.