PDA

View Full Version : big sc problem( i think)



scooby
05-17-2005, 07:36 PM
here it gos i have brand new sc motor .30 over forged pistons a good size cam i was reground,76mm maf C&L,bbk 70mm throttlebody,42 lbs.injectors lucas,stock intake,fuel rail stock,heads have valve job better springs ported and polishedalso milled down,brand new plugs and wires motocraft,bhj blancer,95 blower ported,underdrive pulley, rasied top!!!!!!!!!!ok motor sparks gets gas and have very good cylinder pressure!!!!it will start then maybe ten seconds later i just dies!!!!!!!!SOMEBODY PLEASE HELP!!!!!!!!!!!im about to show an sc what a 12ga is!!!!!!!!!!!!!!!!!

rsliger98
05-17-2005, 08:19 PM
vacuum leak is what it sounds like that is the number one cause of our cars doing that.

talonhead
05-17-2005, 08:27 PM
ditto. mine did that when I put it back together after doing HGs. Hard vac tube on recirc valve cracked.

Willy
05-17-2005, 09:14 PM
here it gos i have brand new sc motor .30 over forged pistons a good size cam i was reground,76mm maf C&L,bbk 70mm throttlebody,42 lbs.injectors lucas,stock intake,fuel rail stock,heads have valve job better springs ported and polishedalso milled down,brand new plugs and wires motocraft,bhj blancer,95 blower ported,underdrive pulley, rasied top!!!!!!!!!!ok motor sparks gets gas and have very good cylinder pressure!!!!it will start then maybe ten seconds later i just dies!!!!!!!!SOMEBODY PLEASE HELP!!!!!!!!!!!im about to show an sc what a 12ga is!!!!!!!!!!!!!!!!!


Hey Scooby 12ga will only create more problems. Is this just after motor install? these fords will fall on there face when they try to idle after battery has been disconnected. The pcm needs to relearn have you tried driving the car. After driving certain amount of miles should be ok. If not I would lean towards vac leak, dosent neccesarily have to be a broken line could be cracks small and hard to see along lines.