PDA

View Full Version : Transmission problems



Geevaaa9112
06-19-2005, 05:41 PM
I have a 93' SC automatic. My transmission shifts decent w/ casual driving. But when i hop on it, i get a serious transmission shutter, usually in 3rd and 4th gear, also when it downshifts from OD to 3rd it slips a little bit. Both of these may be different issues. But do u think tranny mounts could make the tranmission shutter, it just seems like the tranny is loose and when i give it hard gas the torque is to much and it moves around causing it to shutter badly. Anyone w/ any insight on this would be greatly appreciated.

David Neibert
06-19-2005, 07:52 PM
I have a 93' SC automatic. My transmission shifts decent w/ casual driving. But when i hop on it, i get a serious transmission shutter, usually in 3rd and 4th gear, also when it downshifts from OD to 3rd it slips a little bit. Both of these may be different issues. But do u think tranny mounts could make the tranmission shutter, it just seems like the tranny is loose and when i give it hard gas the torque is to much and it moves around causing it to shutter badly. Anyone w/ any insight on this would be greatly appreciated.

Sounds like the direct drive clutch pack is slipping. Check to make your TV cable is still attached to the throttle linkage and check you fluid level. If both of those are okay...it's probably time for a rebuild.

David

Geevaaa9112
06-19-2005, 08:36 PM
Sounds like the direct drive clutch pack is slipping. Check to make your TV cable is still attached to the throttle linkage and check you fluid level. If both of those are okay...it's probably time for a rebuild.

David



Ya i checked the fluid it is fine, the cable is still attached, i went under the car to find the tranny mount is broken.......im gonna replace that with a solid rubber one.....im gonna try that, then im gonna get it rebuilt if that doesnt solve it.....On the rebuild im goin to get a shift kit, and i noticed that the stock shifter only has 1 d and od, so what is a good shifter for this car, i was thinkin a BM t handle shifter.....thanks for the help, anymore help is appreciated

David Neibert
06-19-2005, 11:05 PM
Ya i checked the fluid it is fine, the cable is still attached, i went under the car to find the tranny mount is broken.......im gonna replace that with a solid rubber one.....im gonna try that, then im gonna get it rebuilt if that doesnt solve it.....On the rebuild im goin to get a shift kit, and i noticed that the stock shifter only has 1 d and od, so what is a good shifter for this car, i was thinkin a BM t handle shifter.....thanks for the help, anymore help is appreciated

The shifter isn't the problem, it's the valve body. If you want to get a revised shift pattern and a good shift kit all in one, get a Lentech Street Treminator Valve Body with electric OD delete.

David