PDA

View Full Version : need help



shmeeman
07-01-2005, 05:01 PM
i just had a 94 5-speed engine(EGR) and i want to put in my 35thand i know it will work.i finally got to talk to the kid that had the engine.

here we go.the engine was a recalled engine and ford rebuilt or bought a new one.he only put about 1000 miles on the car and thats when all hell broke loose.He put a set of kooks mid lengths headers on it and a full SCP exhuast with no cats.

now the real problem with the car was buckin and poppin and the headers where cherry red looked hot enough to stick screw driver there them.He pulled the engine and he said the only thing he could find was a couple of vacum hoses that where a little hammered but should be fine.Then i looked at those things kooks called headers and the EGR tube was broke at the base.He never fixed it he just got P.Oed and sold the car and gave me the engine.His dads shop put the new engine for the buyer and know the car runs good minus the headers
and magnaflow res.

what should i check out on this engine before install.this is a pretty good score,a new to me engine with a 1000 miles on it.any advice would be awsome i need my 35th back on the road i miss that more than caddy

shmeeman
07-04-2005, 11:48 AM
can anyone help me please

AnnivSpeCpe
07-04-2005, 02:21 PM
Running extremely lean, prob because of large vacuum leaks. Make sure all vacuum source connections are leak free, and the intercooler tubes are sealed properly. Now, if you're asking what to check before install, if you aren't disassembling the engine I would do a compression check and go ahead and install it. Good luck, John

shmeeman
07-05-2005, 03:30 PM
thanks alot.i am going to do a compression test before install and again Thank you