PDA

View Full Version : Spinning out of control, oil filter housing and over heating



roy_b
10-03-2005, 09:00 PM
Spinning out of control, oil filter housing and over heating

I had taken my 91 sc in to have the oil filter housing o-ring changed and the wires and plugs. There was a bad oil leak under the car, and the mechanic pointed out where it was coming from. After the o-ring was changed, the car started to really run hot! It always ran warmer then most up around the L in normal. Then, the white smoke started to come out the tail pipe. He said it was the head gasket was starting to go. Itís just funny after he had changed the o-ring all this started to happen.
Day two, after work my boss went down to the shop with me, since my other car is used by my other half. He said that the fan was coming on, and that it was ok. But it still read into the red. He changed the wires with the OEM ford replacement, double platinum plugs. The engine ran awesome! But the Temp gauge read over heat. He said that the temp was 180 running the car with out a thermostat. My bossís brother owns a body shop, so it was off to talk to him since I really trust him. As we talked about the head gasket he said he smelled anit-freeze. He told me a head job is around 1500 to 2000. But he looked under the car and the oil leak had come back, plus the low outang gas sound plus loss of power to?
The question is?
Could some how the anti-freeze lines to the housing or if the o-ring isnít put in right, could that make the loss of power? Also the white smoke out the pipes?

rzibilske77
10-03-2005, 09:10 PM
ummm...overheating and white smoke out the tailpipes is your dreaded hg's :mad:








Spinning out of control, oil filter housing and over heating

I had taken my 91 sc in to have the oil filter housing o-ring changed and the wires and plugs. There was a bad oil leak under the car, and the mechanic pointed out where it was coming from. After the o-ring was changed, the car started to really run hot! It always ran warmer then most up around the L in normal. Then, the white smoke started to come out the tail pipe. He said it was the head gasket was starting to go. Itís just funny after he had changed the o-ring all this started to happen.
Day two, after work my boss went down to the shop with me, since my other car is used by my other half. He said that the fan was coming on, and that it was ok. But it still read into the red. He changed the wires with the OEM ford replacement, double platinum plugs. The engine ran awesome! But the Temp gauge read over heat. He said that the temp was 180 running the car with out a thermostat. My bossís brother owns a body shop, so it was off to talk to him since I really trust him. As we talked about the head gasket he said he smelled anit-freeze. He told me a head job is around 1500 to 2000. But he looked under the car and the oil leak had come back, plus the low outang gas sound plus loss of power to?
The question is?
Could some how the anti-freeze lines to the housing or if the o-ring isnít put in right, could that make the loss of power? Also the white smoke out the pipes?

David Neibert
10-03-2005, 10:14 PM
Sounds like leaking head gasket. Replacing the plugs will make it run better, but only for a little while.

Fix the HGs and then fix the oil leak. They may be related and they may not be.

David

Jeremy_K
10-03-2005, 10:18 PM
If he removed the cooling lines for the oil cooler there would be air in the system if it wasn't re-bled. You will run hot with air in the system. You shouldn't drive the car in the red. It sounds like the HGs blew. Crack your oil drain plug and see if water comes out before oil. My experience with 2 SCs with blown HGs, that's what happens.
The coolant would not mix with the oil at the oil cooler unless it was severely damaged.

roy_b
10-04-2005, 06:53 AM
the next question is
where on long island, amityville can i get the car fixed. my guy doesn't want to do the job.

Jeremy_K
10-04-2005, 01:54 PM
Do it yourself and learn something! ;)