PDA

View Full Version : Alt. problems



tillotson_david
10-15-2005, 04:02 PM
Hello again! Well here is the problem. Started the car took kids to school on the way there tried to put up the windows and the radio dies. A moment later came back on. Made it to school shut the car off took the youngest inside, and when i came back to start it wouldnt start. Had my dad come give me a jump. Took the car out to his house to replace the valve cover gaskets. Got back in it after charging the battery started up fine but the battery light was on now. Removed the positive cable car died is it the alt. or voltage regulator. Any help would be gratefull thanks guys and gals. :confused:

super-merc
10-16-2005, 12:49 AM
Hello again! Well here is the problem. Started the car took kids to school on the way there tried to put up the windows and the radio dies. A moment later came back on. Made it to school shut the car off took the youngest inside, and when i came back to start it wouldnt start. Had my dad come give me a jump. Took the car out to his house to replace the valve cover gaskets. Got back in it after charging the battery started up fine but the battery light was on now. Removed the positive cable car died is it the alt. or voltage regulator. Any help would be gratefull thanks guys and gals. :confused:
Your title to your post pretty much says it all, replace your alternator and battery and all should be fine especially since you are doing the headgaskets with the upper SC pipe off. Mke sure you get the 120amp alt with the correct pulley for our cars. Seal the SC pipe also

edspringer
10-18-2005, 07:54 AM
My 90 XR7 (now sold) had the same problem. The windows would work spradically along with the radio. If I just touched the switch to turn off the engine, the engine would die and did die a few times on the road. Makes for exciting driving at 70 MPH in traffic. PROBLEM: my ignition switch split. By this I mean the plastic case separates a little causing intermittent contact. You can put spot ties around it to pull it back together or get a new switch. I would get a new switch. I believe they are about $30.00 from Ford and probably available at Advance or Auto Zone.

Ed Springer

94 Red SC Auto: 70mm TB, Fresh Air Intake, Stock 90 SC Pulley, Accel 36# injectors, Scorpian 1.73 Rockers, ARP Head Studs, 190 l/h fuel pump, 180 Stat, Raised SC Top, I/C Fan, Headers, Raven Muffler (no cats) with stock resonators, 3:73 Gears, 76 C&L MAF (Gold Tube), Magnacore Wires, NGK Iridium Plugs, MSD Ignition, TRANSGO Shift Kit, Haydon Auxiliary Transmission Cooler, ProTorque 2500 TC, Tokico Struts & Shocks, Royal Purple Synthetic Lubricants, Optima Yellow Top Battery, American Racing 17 Sniper Wheels, Michelin Pilot Sport A/S.

J.D.
10-18-2005, 10:44 AM
.............Removed the positive cable car died is it the alt. or voltage regulator. Any help would be gratefull thanks guys and gals. :confused:
Don't disconnect the battery while the car is running. This can damage the EEC or other electronics. The battery stabilizes the fluctuating alternator voltage.