PDA

View Full Version : Hard Shudder



Lvcien
10-18-2005, 01:37 PM
The other day I was driving home, crusing about 45, and the car began to shake really bad for about two seconds, the electricity was still there, and the engine didn't make any odd sounds ... felt kinda like a massive miss on all cylinders.. same thing happened again last night, it only happens for a few seconds then stops...
I recently ran seafoam through it for the first time, it's got 141,xxx miles on it..

any ideas?

Thanks.

lube70
10-18-2005, 01:43 PM
I had the SAME PROBLEM!!!!! Years ago, I was riding around and it suddenly felt like it was missing 3 cylinders. Went away in about 30 seconds (feels like forever) and was fine. Happened again the next day, and again the same day. Changed out the DIS module and ALL IS FINE. It sends the signal to the coil to fire. Fixed the whole problem.


Good luck......



Don

Lvcien
10-18-2005, 01:46 PM
I had the SAME PROBLEM!!!!! Years ago, I was riding around and it suddenly felt like it was missing 3 cylinders. Went away in about 30 seconds (feels like forever) and was fine. Happened again the next day, and again the same day. Changed out the DIS module and ALL IS FINE. It sends the signal to the coil to fire. Fixed the whole problem.


Good luck......



Don

I figured it was something with the spark, that'll probably explain the single miss I get every 10 - 15 minutes...

Thanks :)

Lvcien
10-18-2005, 01:48 PM
any another name for the DIS module would be? can't find it at autozone..

thanks again.

XR7inWI
10-18-2005, 02:41 PM
I believe they (as well as most others) list them as an "Ignition Control Module".

Tracy

Joisey Jim
10-19-2005, 12:36 PM
Are you getting any 'check engine lights,' because normally when the DIS starts to fail you'll get a bad coil code. If your SC is a 94/95 auto - then it's also possible it's a torque converter shudder - but at 45mph you should already be in overdrive.