PDA

View Full Version : Aod Blues!! Any Help Appreciated



beeturbo
01-26-2006, 11:26 PM
Its Been Hell Just Replaced Engine And Trans In My 90sc..i Installed A Superior Aod Hp Shift Kit , Also Sonnax High Ratio Boost Valve
A+ Billet Super Od Servo, Hd 2-3 Accumulator, And 2400 Stall Converter. It Took A Good While 2 Make The 1-2 Shift Due To A Little Too Much Throttle Pressure So I Readjusted The Cable .. But It Took A Long Time To Make The 2-3 .. So I Remembered What A Friend Of Mine Said About Sticking Valve Bodies And To Shift It Into Reverse A Few Times While Driving Forward .. Well After Doing That It Went Into 3rd Twice But Only While Into The Throttle .. It Never Made A 3-4 Shift But Once I Came To A Stop It Wouldnt Shift Make Another 2-3 Shift .. About A Block B4 I Got Home Taking Off From A Stop It Kinda Shuddered Taking But Again Only Shifted To 2nd. Does Anyone Have An Idea Do U Think Its Dead In The Water Or Simply Possible Sticking Valve Body Or Govenor .. I Wanna Rule Out The Possibilities B4 I Pull It Out And Have It Rebuilt By A Shop .. No More Used Trannys 4 Me .

RBH Racing
01-27-2006, 08:29 AM
into reverse while forward!!:eek: :confused: :eek:


uhhh well, a good scanner can pull trans codes, might want to start there.

22lbsofboost
01-27-2006, 08:51 AM
all that performance stuff in a used trans? did you modify the governer at all?
was it a junkyard tranny or one that you had/knew was good? im thinking governer if its shuddering on a stop. also make sure your TV cable is returning closed. it may be sticking down there at the trans ive had trouble with one where the arm for the TV was sticky as hell

fturner
01-27-2006, 09:09 AM
......uhhh well, a good scanner can pull trans codes, might want to start there.

Ok... this is a new thing.... I've got a '90 like above with an AOD and the last time I checked it did not have a computer module to control it, and to get codes from....... unless I'm missing something.......

As was mentioned, check the TV cable and make sure it has full travel with the throttle body. I lost O/D and almost 3rd and figured I toasted the tranny (still original) but the TV cable at the tranny side was not going all the way home... once I cleaned it up and applied lithium grease on it, the tranny is running perfectly........

I'm still going to swap to a 5 speed though :D

Frit

Kurt K
01-27-2006, 10:19 AM
into reverse while forward!!:eek: :confused: :eek:


Actually, I've done this to free up a sticking valve before, except I was told to go all the way into park and then back into drive while traveling about 10-15 mph. I couldn't believe my tranny builder actually told me to do that. Anyway, after a couple of dry runs while parked, I got up the nerve to do it.

Sure enough, the sticking valve freed up and everything was fine.

If I recall, my problem was that the car wouldn't downshift into 1st when I came to a complete stop...it would start out in 2nd gear.

1956Wildcat
01-27-2006, 10:52 AM
Are you checking the TV pressure with a gauge? I've built and installed several AOD's and I've found they shift better at 35psi. Ford recommends 27 to 32 I believe. Other than that I would look back at any information that came with the shift kit. Some have different springs and adjustments that can be made to the valve body to get the desired shifting. I've used some Superior shift kits, but prefer to stay with the TransGo's, at least in the vehicles I have worked on. Also, you may be able to call Superior directly and ask them for technical help.

Dirtyd0g
01-27-2006, 03:19 PM
The park while moving thing does work, always kinda scared me too but it works.
Technically while moving like that park shouldn't really engage and if it does the back half of the transmission will just rip off nothing major :P
reverse while going forward is destructive.
Alan

Terrible Juan
01-28-2006, 04:30 AM
Are you supposed to jam it into park really quick and they put it back into drive? What exactly are the steps?

Dirtyd0g
01-28-2006, 02:28 PM
Yes but don't do it unless you really need to.

beeturbo
02-14-2006, 06:06 AM
hey guys i appreciate evryones help and advice.. pulled the trans back out and found that the input shaft snapped off in the transmission . my question is is this common . ui just installed another one with all the before listed components, what makes the shaft snapped ir did shifting it fro drive to reverse trying to free the valve body break the input direct drive shaft..the engine is stock with a 2400 stall converter so will th shift kit and converter make it break again ??

sizemoremk
06-05-2006, 03:50 PM
What ever happened with your tranny?

Thanks!