PDA

View Full Version : Hard Starting Help ??



3.8Less
04-01-2006, 12:06 AM
I really hope you guys can help me out with my 90 SC Tbird. I've searched it and got alot of ideas but I still have a few unanswered questions. Do all SC require the brake to be pressed for the car to start up ? The car seem to run fine once it's on. The car has trouble starting up though. I thought it might be the Cam Sensor but nothing I replaced it and then my tach & speedometer wouldn't work? Maybe I left something loose but the car run good it just didn't read. When I'm trying to crank it over after awhile the starter seems heavy won't turn over as easily. I've had the DIS tested already. Any ideas ? Crank sensor would it run bad once it starts ? Thanks in advance

Frank

Spider
04-01-2006, 12:31 AM
Do all SC require the brake to be pressed for the car to start up ?

mine does :)

shadow357x2
04-01-2006, 12:37 AM
I believe just the 1990 models do. Ive had 3 902 and an 89 ,93,94 and the 90 was what I call the brake pedal model.

S

kalipso
04-01-2006, 03:08 PM
Hello Frank, I too had the same problem and change all the sensors, I found out if you make a quick start with a quick turn on the keys it start ok, If you miss that start then I have to turn it 3 times before it starts again. I an assuming it may be the fuel pressure, because there is ignition sparks when I try starting. My next check will be on the fuel system. I think you should do the same, since we both have the same problem. My car drives fine.