PDA

View Full Version : dash lights no go



Merlon
05-08-2006, 01:53 PM
i tried searching this forum for help on finding or fixing my dsah light problem but kept getting sidetracked with interested stuff.
so i am hoping someone out there today knows what might be wrong with mines, and will be willing to tell me or point me in the right direction

i have cel lights, and all that, i have the interior lights, and aftermarket stereo lights, and headlights all working. so why no dash lighs?

maybe my car wants me to speed at night?

i put in a new (to me) light switch knob, and have previously relied on the auto headlights. the dim function doesnt work, if you have auto headlights, you know what i mean, rolls up and down whatever, the car always had dash lights, now i cleaned and re applied a better heatsink grease to the cars dis, but got hungry and ate then came back out and turned the key, and remebered that i hadnt plugged the dis in when the car wouldnt start. so i plugged it in, and now the dash lights wont work. related? where would the fuse be, and should i just rip that dash off and make sure it isnt the dim funtion? because usually the aftermarket stereo will get darker at night, and it doesnt any more? so ~~~?

90coug
05-08-2006, 03:08 PM
where would the fuse be, and should i just rip that dash off and make sure it isnt the dim funtion? because usually the aftermarket stereo will get darker at night, and it doesnt any more? so ~~~?


I would check the fuse boxes, I'm not sure which one it might be in but they are located

Under Dash
Under Hood over by the battery.

Maybe try a new dim light switch? :confused: No ripping or it's going to look like chit :p

shadow357x2
05-08-2006, 03:56 PM
under the hood check the 30amp fuse in the box behind the battery, I believe thats its the "C" fuse. Mine looked ok with simular problems but after getting ready to put a fire under it a checked it with a mulimete and found it to be bad, looks can be deceiving. That may or may not be it but its a start. Also as 90 coug said check your dimmer funtion on the switch and the haarness behind the switch maybe a wire pulled back on you.



S