PDA

View Full Version : Chitty-Chitty-Bang-Bang.......HELP!



tbone
08-06-2006, 08:57 PM
I'm posting about the wifes' car; 1989 XR7 w/ auto. Only 86,000 miles, never been in snow, scheduled maintenance (and then some) always done. Here's the problem; we went to the local drive-in for a bite; car ran flawlessly (as always: it has never been hammered; hell, I don't even get to drive it). Anywho, after we were on our way home, :confused: it just died coming to a stoplight. After a few cranks, off we go, only to stall again. Tach became very erratic; felt like it was starving for fuel. Made it home, let it sit overnite and went out the next day. Same scenario; nuts! Asked around locally what to look for and the consensus was a bad fuel pressure regulator. I picked one up from NAPA, but to tell the truth :eek: I CANNOT FIND THE DARN THING! Can somebody please point it out (and please, please, please let it not be buried under something).

Was also wondering if (when I find it) is this a direct bolt in or are there any issues associated with replacing the FPR? The local shop changed the valve cover gaskets for us; now the owner doesn't want to ever see the car again; some people have no sense of humor even when you're paying top dollar!

Thanks everyone,

Tom

birds4us
08-06-2006, 09:14 PM
I would suggest a cam position sensor, not the regulator. Easier to install as well.

rickbtbird
08-06-2006, 09:15 PM
Hey tbone,
The FPR is located on the fuel rail in the back. I don't know if it's possible to replace it without removing the entire fuel rail but for sure you have to depressurize the system before you do it. When I replaced the o-rings on my injectors I had taken off the entire intake and fuel system at the motor (for other reasons). The bolts that hold the FPR on are in a tight spot as well. Hope you got a few days if you plan on doing it yourself.

I know for sure there's a pressure test you can do to verify it's bad. I'd do that first.

Also.. your problem could be a sensor.. Do you get a Check Engine light too?

scbird1
08-06-2006, 11:27 PM
I would suggest a cam position sensor, not the regulator. Easier to install as well.

Im with him . That FPR is harder to change then my wifes mind. Check your balancer and make sure you don`t have a upshift lite while cranking. Do a search on balancers.

ebodycab
08-06-2006, 11:36 PM
Im with him . That FPR is harder to change then my wifes mind. Check your balancer and make sure you don`t have a upshift lite while cranking. Do a search on balancers.
could also be a fuel pump?...my 91SC had same symptoms 2 weeks ago and it turned out to be a bad fuel pump.

rickbtbird
08-06-2006, 11:44 PM
could also be a fuel pump?...my 91SC had same symptoms 2 weeks ago and it turned out to be a bad fuel pump.
There's a checkout for the fuel system in the after market manuals. If you got a pressure gage, it's easy as hell to do.