PDA

View Full Version : paid membership but nothing. anyone else?



mc94xr7
10-29-2006, 05:21 PM
Anyone else paid membership and see no results and never any feedback when you ask the guys incharge what is happening. its been months since i paid. so i ask the fellow members. and i hope i get some help. sorry for all the negatism.:eek:

gldiii
10-29-2006, 05:31 PM
What is the problem? No ONE has ever been ripped off for membership here. If there has been some issue with access, we always extend the length of membership.

We have been slow in answer the scguys mailbox over the last few months, but are making every effort to catch up. You can either post your specific issue in this thread or email me at my adress below. We make EVERY effort to clear up issues or we will issue a full refund of your dues.

I'll need information on how and when you paid. If you paid by PayPal, which email address was on the PayPal account. If you paid by mail, I may need a copy of the cancelled check.

Randy N Connie
10-30-2006, 09:04 AM
I have looked around for a U.S. Mail address, to send in my dues.
Cant find an address anywhere to pay dues. I no longer use Paypal.
So now I am not able to be a member any longer.

Thanks Randy

Kurt K
10-30-2006, 09:56 AM
I think George has posted the address before, and I'm sure he will either send it or post it when he reads this your message.

gldiii
10-30-2006, 10:38 AM
To get payment information, simply fill out the Join form from the main www.sccoa.com page. This needs to be filled out for new and renewing members. Once that form is filled out, the second page will show payment amount and payment options.

And, YES, Randy even people that don't use PayPal or PCs can be a member! :D

Most current member information is always in the sccoa.com forum as a sticky post. (That is this forum, so I know you can find it.)

http://www.sccoa.com/forums/showthread.php?t=82622

I wonder what happened to the original poster of this thread?

XR7 Dave
10-30-2006, 10:41 AM
double post...

:)

mc94xr7
10-30-2006, 02:46 PM
reciepts sent

gldiii
10-30-2006, 07:23 PM
mc94xr7, I have not recieved your email. Did you sent it to gdavenport@sccoa.com as requested?

blkthndr
10-30-2006, 11:37 PM
George,

I think the issue is that this is Nathan Bialy, who told us his forums id was 94xr7... member #3057

-Ron

gldiii
10-31-2006, 07:20 AM
Ron,

That is what I suspect. I have emails out to him to verify that and get his membership access on the correct account.

mc94xr7
10-31-2006, 10:37 AM
George,

I think the issue is that this is Nathan Bialy, who told us his forums id was 94xr7... member #3057

-Ron

Yo!:D No, this not Nathan Bialy. s:o :eek:

mc94xr7
10-31-2006, 10:44 AM
thanks for the help guys, good customer service- this was my bad- a type o of accidently using someone elses id. sorry for the confusion and keep up the good work. hope to be able get in to the private forums soon when they are activated

gldiii
10-31-2006, 01:17 PM
Nate, everything should be working for you now.

mc94xr7
10-31-2006, 03:20 PM
Nate, everything should be working for you now.
nope I think that i dont know

mc94xr7
06-10-2012, 11:46 PM
Please someone, delete this thread. thank you