PDA

View Full Version : Something broke in my clutch pedal.. ideas?



92bird
02-21-2007, 02:13 AM
Was driving the SC around today and went to shift to third and the clutch pedal made this loud "click" and now its really sloppy.

Car is still drivable and shifts fine, but the pedal is loose and every 4 or 5 times I depress it it makes the loud "click" again.

What did I break in there, and how do I fix it?

Any help is appreciated.

Thanks,

Jeramie

XR7 Dave
02-21-2007, 08:47 AM
You lost the plastic clip that holds the pedal to the master cylinder push rod. Very likely it may have been broken for awhile and both parts may be badly worn out. If you get your head under there it should be fairly evident...

fast Ed
02-21-2007, 10:35 AM
Hey Jeramie

To save you some trouble when you go to order it, the latest p.n. for that clip is 6C3Z 7A581 A. It's not illustrated in the catalogue for the 89 - 95 cars, so unless the parts person knows off the top of their head what the basic number is, they'll likely have trouble finding it. ;)


cheers
Ed N.

92bird
02-21-2007, 12:12 PM
Thanks Ed and Dave!

I'll have to get under there today with a flashlight and see how bad the pedal is. Hopefull its ok and all I need is the clip. If its worn, I'm guessing my only option is the junkyard?

Jeramie

Pit Bird
02-22-2007, 12:56 AM
I bought one from ford yesterday. They had to order it and it took one day to get it. The part listed for $9.49 and as far as getting one out of a bone yard I would forget that I do no think you could get one out without destroying it. Go for the new one you will be happy with the $10 fix

92bird
02-22-2007, 01:42 AM
I bought the clip new from ford for the same price. THey had it in stock.. I was talking about getting a new pedal from the j/y if it was damaged.

Pit Bird
02-22-2007, 02:10 AM
They do not really get damaged unless you ride it for a while with the clip missing and use something to hold the rod on the stud. Then you sometimes wear a grove in the stud and the new clip will not go back in completely right and it will break again fast. The clip can be a pain to get in. If your stud is in fact messed up let me know I will see if I can not help you out with another pedal but if it just started poping you should be ok.

92bird
02-22-2007, 02:03 PM
Cool thanks,

I'll take a look under there today.

Jeramie

David Neibert
02-22-2007, 02:29 PM
Cool thanks,

I'll take a look under there today.

Jeramie

Jeramie,

If that metal ball that sticks off the pedal is screwed up, I know an easy way to fix it.

George, Duffy and I colabrated on a bolt on replacement several years ago, and I made around 40pcs that were donated to the club. I'm sure George can hook you up with one if you make a small donation to the club.

David

92bird
02-22-2007, 03:15 PM
Just took a look under there.. Its pretty messed up.

I remember when I replaced the master cylinder about 3 years ago, that the original clip was broken. The new master cylinder came with a new clip, and I guess it only lasted 3 years (about 11,000 miles for my SC) since the rod was messed up.

I'll email George and see if he can send me the fix. I will of course make a donation to the club.

Thanks!

Jeramie