PDA

View Full Version : Some questions (Lentech/general trans. stuff)



Barrett
07-14-2007, 07:03 PM
Ok, I have a '90 SC.

It has a rebuilt AOD with the Lentech VB.

Now.

When I got the car, the switch for OD kind of fell off.
So I hooked up a new one.

Last night was the first time I was able to get it on the highway.
It doesnt seem like OD works. the RPM stays at 4000 or so
at about 60-60 mph
(the car has 4.10s so obviously itll be a little high, but it still doesnt feel right)

The OD switch definitely has power (not a difficult thing).

So
Things Im noticing (in short):

1. the od switch seems to do nothing
2. when the switch is 'on' it still shifts auto even when im in low gear trying to shift manual
3. every so often if i step on it a little to get up to speed, i notice VERY soft shifts, as opposed to the typical firm shifts of the Lentech.

questions:

1. what would cause this?
2. dumb question: what is exactly the best way to make use of this VB? if the od is locked out, if i put it in d/3 will it still auto shift just without OD?

sorry for the long post

Scott Long
07-14-2007, 10:06 PM
1 is 1st, D is 2nd, OD is 3rd/OD. If you flip the switch it will not go into overdrive if 12+ is going to the solenoid in the trans. You can put it in D and hold 2nd gear. If you leave it in OD it will shift like a normal auto but should shift firm. With the OD switch off it's a normal 4 speed auto, with the switch on it won't shift out of 3rd so when you race you want to keep it in 3rd and you don't need OD at the track.

You might want to check the tv cable tension, there is an article on tccoa.com that shows you how to set it. I put mine on full firm and the trans shifts very firm. I get 1-2 and 2-3 rubber at just less than half throttle.

If it's not going into OD at all thats not good.

Click this: http://www.tccoa.com/articles/tranny/tv-ajust/index.shtml

Barrett
07-15-2007, 12:33 PM
Thanks.

I'm starting to wonder if I just THINK I don't have OD.

At what point/RPM is it suppose to shift into OD?
(it goes 1-2-3-OD?)

Because if i do step on it on the highway, it almost feels like it wants to/should shift into a fourth gear but it never has. Im also afraid to push it too far past 3000 RPM though at that point.

EDIT:
also, as I said...when I try to manually shift (OD off) I can't. Any suggestion (guys?)

Melon
07-15-2007, 01:07 PM
When I first got my Lentech trans, I didn't have the OD delete wired up for a while and the car still shifted into OD because there was nothing wired up to stop it.

Whether you manually shift or let the car shift - it should still go into OD. I'm with Scott - check the TV cable. Chances are, that could be the issue.

-Melon

Barrett
07-15-2007, 01:27 PM
The more I think about it, the more I'm thinking the TV cable.

It would make sense. (IE: incorrect line pressure causing it or something)


It's funny because I JUST dealt with this with my 84 cutlass that I put the 2004r in...lol

Damn TV cables won't let me be.

Scott Long
07-15-2007, 01:58 PM
My car with max tv pressure will hold 3rd to 55mph, as soon as I let up it shifts to OD. If I don't let up it will hold 3rd to around 65-70 at very light throttle and then shift on its own.

If I put it in 1, it will hold first till I put it in D and it will chirp the tires and shift to 2nd if I'm on the gas at all, if I am coasting and put it in D it will just upshift. Same with third, but it won't always chirp the tires to third, I have to be more on the gas.

supercatxr7
07-15-2007, 05:18 PM
Sometimes the solenoid can go bad. I had this happen once. When it goes bad it will not lock out overdrive, it will shift normally into OD.