PDA

View Full Version : check gauges and now oil pressure!!!



Ed's95SC
07-21-2007, 11:23 AM
So 4 days ago the check gauges light comes on and the oil pressure was stuck on the far left. About 2 miles later it pops back over to the norm and the light went off. Did it again yesterday and now the oil pressure is reading O and N but it seems to drop to the left of the N. Started the car and peeked into the the oil filler and saw some oil start to flow but not sure how much I should be seeing. Afraid my pump might be bad:mad: . Any ideas would be great, I really would like to drive instead of look at in the garage.

Kurt K
07-21-2007, 11:31 AM
The factory oil pressure gauge is essentially worthless. Your 0 reading very well could be a loose wire on the sender. In the past I've pulled the wire off the sensor and pinched the connector a little tighter with a pair of pliers and then reinstalled the wire.

If you truely believe you have an oil pressure problem, you need to buy a real oil pressure gauge and check it that way.

Ed's95SC
07-21-2007, 11:56 AM
So I went and crimped it and it is right on the R, so that is better. but of course one of my hoses has a small hole in it and is now sprays out coolant:mad: . But this works, I think I will give it a good flush while I am at it.

sinhumane
07-21-2007, 01:18 PM
yeah, its a wire.. i had the same problem as you a while back... it also f*cked with my TPS.... that was a pain... made my lx slower than it already was... like adding insult to injury.