PDA

View Full Version : Slowbrokebird needs help



Slowbrokebird
08-10-2007, 11:22 PM
Smile Slowbrokebird needs help
I've been trying to get on here for the last 2 mo finally had to ask my wife to help me out ten minutes later here i am. Maybe now i can enjoy the benifits of a SC instead of the headache ive been having. haha::
Edit/Delete Message

thunderkid84
08-11-2007, 12:28 PM
u know....u've got all 10 of your threads on the first page and they all ask about the same questions. u dont need to make a new thread evertime u have a question. u can post every question u have in one thread and and i promise u, we'll all see it.

im going to sum up all your quesitons in this thread:

i dont know what the hell you're using to read real-time data from the EEC, but your most likely using a code reader on the EEC test plug under the hood. are u getting a check engine light ? pull the codes and see what u get.

before u go asking everyone in your area for help did u even try to work on the SC yourself ? SC's are time and money consuming. if u dont have patience or $$ i suggest u get rid of it now.

take the advice of the people telling you to replace your spark plugs and wires. most of them have more experience with and more knowledge of the SC than most mechanics i've talked to. and use motorcraft plugs and wires.

and finally, please do a search. i've learned more from taking the time to read past threads than actually asking the same question in a new thread.

Jason;)

Slowbrokebird
08-11-2007, 12:57 PM
Im learning slowly but surely. Well i had someone else working on it because i havnt been able to DOC wouldnt let me. But now i m free and going to try to do it my self. I wont post ne more threads its just im finally able to use this site so got a little thread happy.Ive been waiting a long time

the-big-e
08-12-2007, 11:33 AM
Where are you located.....

thunderkid84
08-12-2007, 11:55 AM
ok lemme get this straight....

you paid $5250 for a shop to put in a new motor and it has :

-bad spark plugs and wires
-a broken balancer
-ground straps missing/disconnected
-and cant drive it at all(no power)

someone screwed you big time.....u must not have known what u were getting into.

Slowbrokebird
08-12-2007, 01:06 PM
I can drive it i jus cant get the car to get over 45mph and it takes forever to get it going that fast. The installer was supposed to have put new plugs and wires but dont think that happend. So i changed last night and got rid of the bucking.Now driver side manifold glows after 3 min.

Slowbrokebird
08-12-2007, 01:10 PM
I Dont know if the balancer is bad I know the plastic cover behind it is bad that has timing marks on it. And ifound aframe to body ground strap and a block to battery