PDA

View Full Version : My new lock and tumbler from Auto Zone worked, but....



dirtybird91
09-01-2007, 11:59 AM
I turn my car on and my brakes dont work at all until i turn the key backwards about one cm. When I do that I can feel the brake pedal soften up and the brake lights go off in my dash. I have to do this each and every time I start the car, or I don't have brakes!!:mad:
I just bought a new lock and tumbler a few months ago because the old one was worn out and actually got stuck and would not turn.
Anyone else ever had this problem with the brakes???:confused:
Frank

scbird1
09-01-2007, 01:02 PM
Check your ignition switch. Make sure it has not started to come apart. If so just take some zip ties and tighten it up.

dirtybird91
09-01-2007, 01:24 PM
Check your ignition switch. Make sure it has not started to come apart. If so just take some zip ties and tighten it up.

I will check it out. Do I have to take out the lock and tumbler again?:confused:

scbird1
09-01-2007, 01:36 PM
Not at all. Just the cover around steering wheel.

dirtybird91
09-01-2007, 01:41 PM
GREAT! Thanks man!:D
Frank

birds4us
09-01-2007, 01:50 PM
I agree, sounds like an ignition switch.

dirtybird91
09-01-2007, 01:52 PM
I agree, sounds like an ignition switch.

Cool, I will tackle this when I get off work.:cool:

decipha
09-01-2007, 02:25 PM
ignition switch it sounds like as well, i believe i payed $15 for a new one thru autozone, but that was some time ago i have no idea what they go for now

watsonlk
09-01-2007, 05:44 PM
Two days ago I just started having the same issue with my brakes, but more often my Climate Control display and AC won't work unless I move the key back about the same cm you are talking about.
It's working OK now but I know I'm gonna have to replace the switch.

dirtybird91
09-05-2007, 07:37 AM
Two days ago I just started having the same issue with my brakes, but more often my Climate Control display and AC won't work unless I move the key back about the same cm you are talking about.
It's working OK now but I know I'm gonna have to replace the switch.

This was a great post guys!:cool:

sail7seas
09-05-2007, 09:29 AM
I think the Anti-lock brake relay on passenger side firewall should be replaced every 3-5 years.
A failing relay makes the foot brakes feel like inconsistent pressure, and can cause havoc with the Teves.
I'm on my fourth relay, and I did wreck the first Teves with a failing relay.