PDA

View Full Version : Freestar brakes



ThunderDave
11-13-2007, 10:06 AM
My wife was in a little bumper thumper recently in her Freestar. She was stopped behind a BMW suv and glanced up and saw it moving forward and thought the light had changed. (this is why I don't let her drive my SC, although she did drive it to class today, because of the brakes on the Freestar) :rolleyes:

So she gassed it and then noticed the light hadn't changed, but she ended up getting on the brakes hard and still bumped the Beemer. Now the rear brakes were making a loud squalling sound, which has turned into a scrubbing sound.

Is it possible that the brakes didn't release all the way and the pads have been up against the rotors, wearing them out? Could the anti-lock system have been messed up?

Anyone had a brake problem like this before??? Any help will be greatly appreciated. I need to get it fixed, so she doesn't need to drive mine. ;)

fast Ed
11-13-2007, 11:57 AM
Premature brake wear on the rear of the Freestars has been an issue, you're not the only one seeing that. Ford has updated rear pads for them, but I can't say for sure how much of an improvement they are.


cheers
Ed N.

ThunderDave
11-13-2007, 01:21 PM
Thanks Ed. I was always thinking the front brakes went first, since they do more of the stopping. The thing only has 56,000= and I thought it was early for the rear brakes to go. Guess I'll be doing the brakes on it. :rolleyes:

fast Ed
11-13-2007, 01:56 PM
David, I've seen them in our shop with less than 50,000 km needing rear brakes ... that's around 30,000 miles. :rolleyes:


cheers
Ed N.