PDA

View Full Version : Anyone have?



ELSC
05-16-2008, 11:00 AM
Anyone have a spanner nut wrench I can borrow or a cheap one I can buy?
Valve cover on the drivers side is leaking, previous owner sealed the MP top, tried to knock it loose with a rubber mallet and will not budge. I would appreciate the help.
Brian

nwnsc
05-16-2008, 12:37 PM
just take the top and the uper ic tube off in one pieace.

ELSC
05-16-2008, 02:29 PM
Top is glued on.....tried to knock it loose with a rubber mallet did not budge.

the-big-e
05-16-2008, 02:32 PM
Try a strap wrench on the collar nut.....

ricardoa1
05-16-2008, 02:45 PM
Make sure you are removing the nut and stud thats near the PS on the accessory bracket. it holds down that tube. The glue should not be that strong for you now to be able to pry it loose.

Rob m
05-16-2008, 03:33 PM
I just did mine today. I used a large flat screwdriver and a hammer. Not the right way but in a pinch you gotta do what you gotta do

ELSC
05-16-2008, 03:35 PM
Make sure you are removing the nut and stud thats near the PS on the accessory bracket. it holds down that tube. The glue should not be that strong for you now to be able to pry it loose.

I know the stud you're talking about, and that is missing. The top is seriously on there. I tried pulling the top off with all my strength, then tried to knock it off with a mallet.... nothing

ricardoa1
05-16-2008, 03:55 PM
Pry the tube sidways the leverage from the tube should pull it apart.

ELSC
05-16-2008, 03:58 PM
Okay I'll try that thanks.

Gerry Rider
05-16-2008, 04:32 PM
A length of 2x4 under the nut worked great for me and easy on the aluminum parts. Had been on there for many years and had been really stuck.
Gerry