PDA

View Full Version : Hopefully going to figure out whats wrong with this ~~~



Jacob_Royer
05-18-2008, 12:21 AM
Got the following today

Another blower/inlet plenum

Engine wirring harnes

DIS

COIL pack

(Thanks matt!! hopefuly you found your stuff on my porch!)

Have a set of new wires out here ready to go..

Going to see if all this gets my car running properly again.. last time i had it out i only made 9psi on 10% od.... sad.....

dwayne
05-18-2008, 12:43 AM
think that is the problem with your car,what all is it doing.

Jacob_Royer
05-18-2008, 12:31 PM
No balls since the new engine and cam.... 10.01 11/8th miles from 9.2's stock.. crappy idle... crappy milleage, dies randomly.... 13/14psi with 5% before now 8/9psi with 10%...

eli66048
05-18-2008, 12:40 PM
IC tubes sealed up good? Hoses?

Danny

Jacob_Royer
05-18-2008, 12:42 PM
I've got the teflon seals on everything! cant find any leaks...

Miller
05-18-2008, 12:49 PM
tune / you ported your blower like dog crap ?

Jacob_Royer
05-18-2008, 12:54 PM
Well going to try to get the blower changed this week if i dont have to work a bunch of OT

dwayne
05-18-2008, 03:18 PM
I have a complete stock blower for a 91,about 3'000 miles on it.

Jacob_Royer
05-23-2008, 02:28 AM
Swapped DIS and coil pack.. still runs like garbage.. Going to try to go for the blower plug wires and engine harness tommarow. Started pulling blower tonight how bad does this look to you guys? i think this is part of the problem

http://i20.photobucket.com/albums/b250/jacobroyer/0523080206.jpg

XR7 Dave
05-23-2008, 08:28 AM
Swapped DIS and coil pack.. still runs like garbage.. Going to try to go for the blower plug wires and engine harness tommarow. Started pulling blower tonight how bad does this look to you guys? i think this is part of the problem

The size of the outlet isn't the problem but it certainly didn't help much if any.

Jacob_Royer
05-23-2008, 10:13 AM
Well the case as leaked oil ever since i had it apart so i kinda wonder if it leaks boost also.. Because it gradualy makes less boost.. 8psi is all it has now.

Jacob_Royer
05-23-2008, 10:14 AM
I've got a new bypass valve with it also so i might even try it.

MartianBob
05-23-2008, 10:58 AM
I had a crack in my intercooler once.
It didn't leak under vacuum but my boost dropped from 15 to 8.

Bob