Results 1 to 4 of 4

Thread: this is weird...

  1. #1
    Join Date
    Mar 2004
    Location
    Salt Lake City, Utah
    Posts
    66

    this is weird...

    so maybe this is a SC thing or maybe just mine. When I put the car into reverse the map lights on the rear view mirror go on? It drive me nuts, anyone know why?

  2. #2
    Join Date
    Dec 2007
    Location
    Salem OR
    Posts
    7,494
    What year SC is it...?

  3. #3
    Join Date
    Mar 2004
    Location
    Salt Lake City, Utah
    Posts
    66
    it is a 1990

  4. #4
    Join Date
    Dec 2007
    Location
    Salem OR
    Posts
    7,494
    >it is a 1990

    Pity - my hunch won't wash then, sorry.

    Just the map lights come on, or all of the interior courtesy lights, keypad/lock bezel, etc.? Do the back up lights still work? If you rotate the headlight switch to turn on the courtesy lights, do the back up lights come on as well?

    Best I can do now is ask if you've done, or had done, any work recently? New car alarm or car radio? Trans o'haul? Carpet work? Any recent collisions?

    If the answers are no, and this particular issue seems to have come out of the blue...you might want to try removing the fuses that service the map & backup light circuits - one at a time - see if they both go dead. If this happens, then you can perhaps have a clue if those wires have shorted downstream of the fuse block. Then start finding where those circuits share territory inside the harness by looking over wiring diagrams - have any?

    Wiring can be the worst. This would be a good time to find that rabbit's foot you lost in the trunk last year

Similar Threads

  1. Weird idle problem
    By WhiteThunder in forum Technical Forum
    Replies: 22
    Last Post: 12-08-2007, 08:18 PM
  2. Very weird idle problem
    By chadder1313 in forum Technical Forum
    Replies: 5
    Last Post: 01-31-2005, 12:39 AM
  3. Weird Noise From SC
    By ThunderCoupe94 in forum Technical Forum
    Replies: 5
    Last Post: 04-25-2004, 07:46 PM
  4. weird smell from engine...
    By GREATWHITE666 in forum Technical Forum
    Replies: 2
    Last Post: 09-17-2003, 07:19 PM
  5. What is this weird wobble from the rearend...
    By Blacktbird96 in forum Technical Forum
    Replies: 4
    Last Post: 08-04-2003, 01:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •