Results 1 to 7 of 7

Thread: Have to jump fuel pump relay for engine to run

  1. #1
    Join Date
    Apr 2002
    Location
    Norcross, GA
    Posts
    3,301

    Have to jump fuel pump relay for engine to run

    I've been working on my 89 trying to get it going after sitting for 5 years. If I shoot some starting fluid into the MAF it'll crank up and idle but if I give it any throttle it stalls right out. If I jumper the fuel pump relay at the EEC test connector the pump runs and I can rev the engine but only if it's jumpered. No jumper and it stalls with throttle. Pulling the fuel pump relay kills kills the fuel pump so I know the relay is good. It looks like the fuel pump relay coil connection goes to the EEC pin 22 from the test connector. Could the EEC have failed? Anybody seen this before?
    90 5spd, best ever E.T. 12.250
    best ever 1/4mi speed 112.89 mph
    Current dyno tune 383.54 rwhp 418.88 rwt

  2. #2
    Join Date
    Dec 2007
    Location
    Salem, OR
    Posts
    6,283
    Checked the impact sensor...trunk left?

  3. #3
    Join Date
    Apr 2002
    Location
    Norcross, GA
    Posts
    3,301
    Yes, that's in series with the fuel pump relay coil so if the relay operates and the pump can be jumpered to run it's got to be. I tripped it and reset it just to be sure.
    90 5spd, best ever E.T. 12.250
    best ever 1/4mi speed 112.89 mph
    Current dyno tune 383.54 rwhp 418.88 rwt

  4. #4
    Join Date
    Dec 2007
    Location
    Salem, OR
    Posts
    6,283
    Any chance the car was equipped with a security system & drive-away cut-off?

  5. #5
    Join Date
    Apr 2002
    Location
    Norcross, GA
    Posts
    3,301
    It does have a security system but it was never a problem in the past when I had it running. Is there a switch somewhere that needs to be reset, maybe?
    90 5spd, best ever E.T. 12.250
    best ever 1/4mi speed 112.89 mph
    Current dyno tune 383.54 rwhp 418.88 rwt

  6. #6
    Join Date
    Jun 2002
    Location
    Orem, UT
    Posts
    5,902
    At least yours starts. I had to hotwire and switch my fuel pump and then come to find out I have no spark. I put in a new ignition switch, new (used) IRCM and computer, and still nothing.
    Scott Long
    1992 SC 5-speed
    Black on black leather, lowered, 18x9 Chrome Saleens...

  7. #7
    Join Date
    Dec 2007
    Location
    Salem, OR
    Posts
    6,283
    May be time to do the basics...

Similar Threads

  1. I found this FAQ on the SC
    By Active non member in forum Super Coupe Club of Western Canada
    Replies: 15
    Last Post: 12-21-2013, 02:28 AM
  2. can you run a standard fuel pump with 42lb injectors
    By mybirdcanfly in forum Technical Forum
    Replies: 5
    Last Post: 03-03-2008, 09:42 PM
  3. Continued ABS woes (and others)
    By gregs90sc in forum Super Coupe Club of Ontario
    Replies: 22
    Last Post: 07-11-2007, 08:35 AM
  4. Bad Relay Causes Low Fuel Pressure...
    By darkstar_one in forum Technical Forum
    Replies: 0
    Last Post: 11-12-2006, 01:05 PM
  5. Fuel pump relay
    By buggybugster in forum Technical Forum
    Replies: 10
    Last Post: 11-02-2004, 05:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •