Results 1 to 14 of 14

Thread: New time

  1. #1
    Join Date
    Nov 2004
    Location
    Brantford, ON
    Posts
    5,383

    New time

    Went to TMP last night and set a new time...

    ET was 14.142 @ 98.72.

    On average though the car ran consistently in the 14.22x range and trapping on average at 99.3 mph. That includes 8 back-to-back runs without even sitting in the staging lanes. The car is rock solid consistent if anything.

    The one area that is suffering is the 60 foots averaging 2.2x's. Track prep sucked and no matter how much I feathered the throttle the tires spun, unless I went like the dodge charger's there did and granny launched the car .

    She's fighting me to break into the 13's, but gosh darn it she's gonna be there this year if I have to get out and push her.

    Fraser

  2. #2
    Join Date
    Jun 2008
    Location
    Muskegon, Michigan
    Posts
    1,006
    Nothing like good ole' Canadian Igloo racing. Good times for your listed mods.

    Jerry

  3. #3
    Join Date
    Aug 2004
    Location
    KSRQ
    Posts
    5,188
    Real progress there. That's great to hear. Get those tires!

    Ira

  4. #4
    Join Date
    Nov 2004
    Location
    Brantford, ON
    Posts
    5,383
    Quote Originally Posted by Cherry93SC View Post
    Nothing like good ole' Canadian Igloo racing. Good times for your listed mods.

    Jerry
    You just gave me an idea, I should get my dog team hooked up and just maybe I could break into that 13 .

    Fraser

  5. #5
    Join Date
    Nov 2004
    Location
    Brantford, ON
    Posts
    5,383
    Quote Originally Posted by Ira R. View Post
    Real progress there. That's great to hear. Get those tires!

    Ira
    Seriously, I guess it is time for me to look at some tires. With the trap speeds I'm getting, if I can hook up, the car should be able to run mid 13's as it sits now. Its my biggest problem right now.

    Dave recommends I step up since I do so much "testing" and datalogging with the car, hopefully for the benefit of the club, I need to establish a constant base to work from. One thing I need to rule out of the equation is the launching of the car, and running proper tires will help. I've out grown street tires obviously and its hurting the car.

    In the next few weeks I'm installing a few more little enhancements, which will only aggrevate the problem with the existing tires.

    I'm all about maximizing efficiency of the motor and making everything work together in harmony without throwing everything and anything at the car, and I think I've done a good job so far . I just keep forgetting about that stupid little half a square foot of contact to the world that can make or break you .

    Now if only I had an AR to dial in... whoa talk about wicked!!!!!

    Fraser

    ps. Dave has helped alot with the ideas and theories, even though at first he was... kind of doubtfull , but I think its panning out.

    I'm taking any donations towards these tires to better the cause LOL!!!!!! just joking.

  6. #6
    Join Date
    Dec 2002
    Location
    Wintersville, OH
    Posts
    4,091
    you have the trap speeds for sure, I ran 100flat at 13.5 with mine. Have yet to hit that number with the 5 speed

  7. #7
    Join Date
    Apr 2004
    Location
    sumter, south carolina
    Posts
    3,050
    you and i seem kinda close in power. my trap was a 96.6 but time was 14.8. and we had the same 60' time.

    i'm going to be getting some 15" lx rims and probably some 27 X 10.5 bias-plys.

    after a dyno and chip re-burn by dave. i hope that will put down 13's.

  8. #8
    Join Date
    Apr 2002
    Location
    Queens, NYC
    Posts
    1,058
    Have you tried out VHT on the tires yet?

  9. #9
    Join Date
    Jun 2007
    Location
    Whitby On. Canada
    Posts
    966
    Your getting closer Fraser, Keep at it man 13"s are just around the corner.
    ( Or in Whitby sitting in my basement )
    Let me know next time you are going.
    Drew

  10. #10
    Join Date
    Sep 2004
    Location
    Indy
    Posts
    5,623
    That's a good enough MPH to get into the 13's. I would do what Dennis Head said and VHT the tires.

    Street tires are murder to a starting line and too hard of a composition to hook too well, anyways. Try it out sometime. You'll get there!

    Good work, sir.
    1994 SC
    4.5L Twin Turbo SVO
    Project GTFD

  11. #11
    Join Date
    Jun 2003
    Location
    Lexington Kentucky
    Posts
    1,522
    Yep! Like Cmac said the street tires just dont hook that well and please dont do what some idiots at the local track due and "burnout" in the water box with their street tires! LOL
    Anthony Arnold
    Home of "No Cash Racing!"

    Silver 90 AOD 12.03 @ Shootout 2010
    White 94 Auto ??????
    Black 95 5-speed ????

  12. #12
    Join Date
    Nov 2004
    Location
    Brantford, ON
    Posts
    5,383
    LOL! no I don't do the burn out thing. I go around the water.

    I'm looking into getting a set of MT ET Street Radials... might as well do it right .

    Fraser

  13. #13
    Join Date
    Oct 2005
    Location
    Spring Texas
    Posts
    745
    thats more than enough speed for 13's.....

    my last best time was 13.85 @ 96mph.....but with 1.88 60's.

  14. #14
    Join Date
    Sep 2004
    Location
    Indy
    Posts
    5,623
    Quote Originally Posted by fturner View Post
    LOL! no I don't do the burn out thing. I go around the water.

    I'm looking into getting a set of MT ET Street Radials... might as well do it right .

    Fraser
    I always have FAST class in mind, with your car. The right way would be slicks.
    1994 SC
    4.5L Twin Turbo SVO
    Project GTFD

Similar Threads

  1. who all runs 12's?
    By 5speedxr7 in forum Non Technical Forum
    Replies: 43
    Last Post: 12-04-2004, 01:49 AM
  2. 1st time with the 5spd cougar
    By getblown in forum Racing/Track Results
    Replies: 6
    Last Post: 11-23-2004, 02:13 AM
  3. Car Stauling @ The track (my 1st time)
    By SuperCoupeSC91 in forum Technical Forum
    Replies: 10
    Last Post: 09-26-2004, 08:30 PM
  4. ABS Pump Run Time
    By TwoTimeSC in forum Technical Forum
    Replies: 3
    Last Post: 11-12-2002, 09:15 PM
  5. 2nd time at the track (milan). 14.887@93.95 MPH.
    By 91BLOWNSC in forum Non Technical Forum
    Replies: 21
    Last Post: 05-18-2002, 02:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •