Results 1 to 7 of 7

Thread: I hate chasing gremlins!

  1. #1
    Join Date
    Apr 2003
    Location
    Virginia
    Posts
    709

    I hate chasing gremlins!

    I got the car back on the road after a major mod rebuild. Car is running rough,but smooths out when MAF is pulled. I went through that in another thread and that's not my issue here. I'll deal with that soon.

    I limp it to the Muffler Shop so they can weld new downtubes on my exhaust to Kooks Midlengths and install a new bung hole

    Rewind a couple weeks ago- I haven't answered or gave opinion on many threads within the past year or longer, I've been dealing with my own issues. Well, two weeks ago I gave my help on two threads- One dealing with a non-functioning brake fluid pump motor and the other, being how to get to a blown heater core. Well, on my way to and from the muffler shop guess what two things just happened to occur to my car....ding ding, you guessed it! My brakes are as hard as a rock/pump motor not working, and my heater core is leaking!!! My car was smoking coolant from my interior vents and from the firewall and up and out the rear of my hood with the temp. skyrocketing.

    Good thing I didn't reply to that "Valve through the piston" thread!

    It's always something.

  2. #2
    Join Date
    Dec 2004
    Posts
    2,004
    answer:

    set it ablaze, collect insurance, buy reliable transportation

  3. #3
    Join Date
    Apr 2003
    Location
    Virginia
    Posts
    709
    Quote Originally Posted by rzibilske77 View Post
    answer:

    set it ablaze, collect insurance, buy reliable transportation
    Naaa, I resigned this car to be my project car a while ago. Plus, once I get these gremlins out, there's 350-400 rwhp in her.

    As far as the brakes go, it's not the pump motor relay. I swapped that out already. It could be the pressure switch and I actually have a couple extra in my garage. I'm gonna swap them out this weekend to see if that's the problem. On the upside, my down tubes are good and my o2 sensors are now in place.

    I have pretty reliable transportation. My wife has an '02 Escape and I have at '97 Buick Regal GS, which has the cousin to our motor. It's a FWD 3.8 M90 supercharged V6. No intercooler at about 7 lbs of boost max. But, it makes 245 horses.
    Last edited by metalman; 10-03-2009 at 12:33 AM.

  4. #4
    Join Date
    Apr 2003
    Location
    Virginia
    Posts
    709
    I fixed these two gremlins!

    The coolant smoke was not from the blown heater core, but from a loose hose clamp on the in side of the heater core. So, when pressure built up and the thermostat opened it smoked out up the firewall. My heater vents were opened so some smoke probably also got drafted into my car.

    My brake issue was a seized pump motor. I took it out and used a pair of pliers to turn it free, slapped it back in and voila, it works.

    That's 2 gremlins down.

    Now I have to lengthen my 02 sensor lead, cause a relocated bung that I had installed is too far away, even for the long lead sensor I bought. And, then there's the bucking and choking issue. I'll get to that after I fix the O2 problem.

  5. #5
    Join Date
    Jul 2003
    Location
    Eastern (nee Western) PA
    Posts
    4,993
    Just a head's up about the O2 leads ... the jacket around the wires is actually used by many O2 sensors as a tube to "breathe" fresh air ... so don't tape off the upper end or clog it with heat shrink.
    God bless!!!

    Former Birds:
    1990 SC auto ... red outside, gray cloth inside ... ~225,000 miles ... Sold.
    1990 SC auto ... white outside, gray cloth inside ... ~150,000 miles ... wrecked.
    1989 Base auto ... Crystal Blue metallic outside, dark blue inside ... ~160,000 miles ... Sold.

  6. #6
    Join Date
    Apr 2003
    Location
    Virginia
    Posts
    709
    Thanks for that.

    What I was gonna do is make an intermediate plug extension by cutting off the lead from an old O2 sensor which is the male end, getting the pigtail on the main wiring harness end which is the female end and soldering them together to link my O2 with the harness. That way I don't have to relengthen new O2 sensors as I replace them, nor mess with the original wiring harness.

  7. #7
    Join Date
    Jul 2003
    Location
    Eastern (nee Western) PA
    Posts
    4,993
    That sounds like a good idea. I think they sell readymade extenders, but I don't know how much they cost. But reusing the scraps is definitely cheaper!
    God bless!!!

    Former Birds:
    1990 SC auto ... red outside, gray cloth inside ... ~225,000 miles ... Sold.
    1990 SC auto ... white outside, gray cloth inside ... ~150,000 miles ... wrecked.
    1989 Base auto ... Crystal Blue metallic outside, dark blue inside ... ~160,000 miles ... Sold.

Similar Threads

  1. I hate you all!
    By darkstar_one in forum Non Technical Forum
    Replies: 14
    Last Post: 03-15-2008, 11:54 PM
  2. Heritage or Hate?????????
    By dirtybird91 in forum Non Technical Forum
    Replies: 43
    Last Post: 04-01-2004, 05:34 PM
  3. I HATE it when this happens!!
    By FOH in forum Technical Forum
    Replies: 12
    Last Post: 01-24-2004, 08:46 AM
  4. im statring to hate the car
    By turbospeed in forum Non Technical Forum
    Replies: 1
    Last Post: 07-26-2003, 01:25 AM
  5. I hate TORX connectors!!!!!!!
    By Rob Noth in forum Non Technical Forum
    Replies: 4
    Last Post: 03-20-2003, 11:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •