Results 1 to 6 of 6

Thread: engine codes

  1. #1
    Join Date
    Mar 2010
    Location
    Valles Mines MO.
    Posts
    234

    engine codes

    Ok to start off, I am new to the sc's (I mainly know about 5.9 diesel engines)
    I recently purchased a 1994 sc 5 speed local in St.Louis, had bad engine mounts and needed a tune up. Tackeled the engine mounts (not as hard as it looks) after about a week of driving perfect I got a CEL. Took it to Autozone they said TPS was bad code 121. bought a new one put it on and same symptoms (drops below 600 rpm and sounds like a miss and seldom bucking at hwy speed) checked voltage at TPS all was good. Cleaned MAF sensor,replaced all rubber vacuum hose, tightened intercooler tubing flanges and nuts,still same symptoms. Went back to Autozone and bought a code reader for $31.95 got back home plugged her up and did a KOEO test and pulled code 214 stumped me. I am going to do a KOER tomorrow weather permitting. At idle i have 26-28 in HG so i don't think it is a vacuum leak. Will not hesitate to hit 10-12 psi. Has new plugs,wires,coil pack, balancer is true,will check all connectors tomorrow also. I am stumped and need assistance:confused any help is appreciated. Thanks.

  2. #2
    Join Date
    Mar 2010
    Location
    Valles Mines MO.
    Posts
    234
    KOER showed, passed 3 times in a row with a test drive of about 5-6 miles between each test. Also CEL went on and off a few times while on hwy (seems to go off while coasting without foot on the gas pedal down hill) also had trouble starting today. I started car for about 1 maybe 2 minutes shut it off for maybe 3 minutes tops, came out of store and had to turn it over at least 5 times I turned key off then tried again it hesitated so I hit the throtal about half way then it started right up. Put it up on the rack at work today to find some of my idle noise (loose heat sheilding on cat's) so i took it off was barley holding on. thanks for looking thoes who did. still have all problems above and would love some advice.
    p.s. all wire connections were tight, some had missing hold tabs or broken clips but nothing major.
    Last edited by kpoindex08; 04-06-2010 at 10:41 PM.

  3. #3
    Join Date
    Sep 2006
    Location
    NE, AR
    Posts
    1,570
    214 is a Cam Shaft sensor error, so the computer is guessing then it losses signal. They are about $30 so its a cheap part.
    Since its a 94 you might as well get the crank sensor before it dies, its not a bad price either.
    Last edited by bowez; 04-06-2010 at 11:22 PM.

  4. #4
    Join Date
    Mar 2010
    Location
    Valles Mines MO.
    Posts
    234
    Going to get cam and crank sensor today at work. If that does not work I will move to the more expensive MAF and IAC. I might as well put new plugs and wires in just to make sure. That should eliminate all electrical variables. I hate guess work. It is so much more expensive.
    thanks for the repli

  5. #5
    Join Date
    Sep 2006
    Location
    NE, AR
    Posts
    1,570
    By the code the MAF and IAC are not causing it, replace wires/plugs before messing with them. It may not hurt to take the IAC off and clean it, personally I've never need to replace one cleaning has always worked for me.
    Last edited by bowez; 04-07-2010 at 06:17 PM.

  6. #6
    Join Date
    Mar 2010
    Location
    Valles Mines MO.
    Posts
    234
    fixed it was a camshaft poison sensor. runs better than it ever did.

Similar Threads

  1. When is a Coy Miller Race Engine not actually a Race Engine?
    By RalphSparveri in forum Non Technical Forum
    Replies: 130
    Last Post: 04-28-2006, 08:13 AM
  2. Reman engine pulling many codes...
    By 92superJRK in forum Technical Forum
    Replies: 3
    Last Post: 04-23-2005, 06:33 PM
  3. Engine codes?
    By Randle in forum Technical Forum
    Replies: 4
    Last Post: 10-21-2003, 12:21 PM
  4. new engine..fault codes
    By MtDewd in forum Technical Forum
    Replies: 1
    Last Post: 11-02-2002, 03:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •