Results 1 to 5 of 5

Thread: Looking for 94-95 SC ECU

Hybrid View

  1. #1
    Join Date
    Mar 2009
    Location
    Cazzostan
    Posts
    19

    Looking for 94-95 SC ECU

    Looking for 94-95 SC ECU with shipping to Kazakhstan (ZIP 050040).
    Please send me PM.

  2. #2
    Join Date
    May 2010
    Location
    Port Saint Lucie, Fl
    Posts
    137
    Auto or 5 speed?

  3. #3
    Join Date
    Mar 2009
    Location
    Cazzostan
    Posts
    19
    Quote Originally Posted by madebyme View Post
    Auto or 5 speed?
    Auto, AODE

    But if you have ecu for manual tranny give me know, because this is a very long project, I can change my mind for manual transmission)
    Last edited by my0wn3ds; 08-25-2010 at 08:57 AM.

  4. #4
    Join Date
    Nov 2004
    Location
    Brantford, ON
    Posts
    5,383
    Quote Originally Posted by my0wn3ds View Post
    Auto, AODE

    But if you have ecu for manual tranny give me know, because this is a very long project, I can change my mind for manual transmission)
    Actually, the trans is a 4r70w. SC's never received the AODE trans.

    Fraser

  5. #5
    Join Date
    Mar 2009
    Location
    Cazzostan
    Posts
    19
    Quote Originally Posted by fturner View Post
    Actually, the trans is a 4r70w. SC's never received the AODE trans.

    Fraser
    Even in 1989-1990?


    My trans is AODE from 1994'SN-95.
    Will work SC's ECU with AODE?

    ===

    I just found that AODE is not interchangable with 4R70W
    Last edited by my0wn3ds; 08-25-2010 at 03:36 PM.

Similar Threads

  1. beeping ecu?
    By scxr7 in forum Technical Forum
    Replies: 4
    Last Post: 02-03-2010, 07:16 PM
  2. WTT: manual ECU for an AOD ECU
    By plstktnkr2 in forum Trades
    Replies: 2
    Last Post: 10-06-2009, 07:04 PM
  3. `94 SC ECU w/ DiabloSport DeltaChip
    By Bugzturbo in forum Parts for Sale
    Replies: 1
    Last Post: 09-15-2006, 08:46 AM
  4. Need ECU and MAF for 93 SC AUTO
    By RedMosesSC in forum Parts for Sale
    Replies: 13
    Last Post: 04-14-2005, 07:26 PM
  5. Problem Not Cam Sensor..... Fuel Filter maybe?
    By AaronPierre in forum Technical Forum
    Replies: 28
    Last Post: 08-07-2002, 06:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •