Results 1 to 6 of 6

Thread: 90 sc 5 speed no spark just shut off

  1. #1
    Join Date
    Feb 2008
    Location
    Wisconsin
    Posts
    18

    90 sc 5 speed no spark just shut off

    Hey I My super coupe recently shut off on me when I put car into gear with foot still on the clutch. It will turn over but not fire I checked and no spark I have changed parts so far (Ignition module, Coil Pack) I know cam or crank shaft sensor might be an issue. Do you think that is possible. Or what suggestions would you have on getting my car running again I love this car so much but nobody knows much about them. MY girlfriend wants me to sell both of mine but I want to restore. I got a neutral safety switch code stuck open and egr valve when I had a friend test it. But I heard through the grapevine that It would not even turn over if that were the case. My car turns over just wont fire.

    also Do you think I would be getting automatic transmission error codes in my manual transmission
    the reason i ask this is i have had car for three years and never had a problem with that being an issue and The mechanic who is trying to figure it out says he is getting automatic transmission codes and thinks that the wrong eec is in it? which I took eec out now and got this part number I attached a pic of it He is saying that I have wrong eec In their which I know is not the case
    eMAIL [email protected]

    Thanks aaron hansen ajhansen
    Attached Images Attached Images  
    Last edited by ajhansen91; 10-19-2010 at 10:52 PM.

  2. #2
    Join Date
    Oct 2004
    Location
    Charlotte, NC
    Posts
    8,159
    Check for crank pulley wobble while cranking the engine....

    Even a little bit of wobble can cause a no start condition.....

    Also check the bolt that holds the harmonic balancer to the end of the crank shaft.....

    If it is loose or gone, the balancer can walk off the crank shaft a bit.....

  3. #3
    Join Date
    Apr 2002
    Location
    St. Charles, MO
    Posts
    21,138
    Quote Originally Posted by ajhansen91 View Post
    Hey I My super coupe recently shut off on me when I put car into gear with foot still on the clutch. It will turn over but not fire I checked and no spark I have changed parts so far (Ignition module, Coil Pack) I know cam or crank shaft sensor might be an issue. Do you think that is possible. Or what suggestions would you have on getting my car running again I love this car so much but nobody knows much about them. MY girlfriend wants me to sell both of mine but I want to restore. I got a neutral safety switch code stuck open and egr valve when I had a friend test it. But I heard through the grapevine that It would not even turn over if that were the case. My car turns over just wont fire.

    also Do you think I would be getting automatic transmission error codes in my manual transmission
    the reason i ask this is i have had car for three years and never had a problem with that being an issue and The mechanic who is trying to figure it out says he is getting automatic transmission codes and thinks that the wrong eec is in it? which I took eec out now and got this part number I attached a pic of it He is saying that I have wrong eec In their which I know is not the case

    eMAIL [email protected]

    Thanks aaron hansen ajhansen
    Picture of the EEC is too small to read the numbers. As was mentioned earlier in this thread, sudden loss of spark is usually caused by the balancer starting to fail or failing and damaging or loosing contact with the crank sensor.

    David
    1991 SC AOD 4.2..2.3 Whipple..........10.910 @ 125.61
    2016 SRT Challenger Hellcat.............10.597 @ 135.78

    My Garage

  4. #4
    Join Date
    Dec 2009
    Location
    Toronto
    Posts
    2,103
    I'm thinking 66-67 for the Safety Switch Code.

    I got clean code confirmation with this code. I think its because clutch isnt pushed when codes are read.

    I think you have to go back to beginning and check the basics for no start..

    With no burps to make you feel good either spark or fuel.

    Paul

  5. #5
    Join Date
    Feb 2008
    Location
    Wisconsin
    Posts
    18

    reply no spark 90 5 spd Aaron Hansen owner

    I did get the 67 neutral safety switch and codes were taken when car was being turned over But I was told that the car would not turn over if that were the case it. My car turns over fine when you push in the clutch I just have no spark The engine was running i put the car in gear and it just shut off. I did disconnect battery to try to reset. when I reconnected battery codes that showed up were 67 for neutral safety switch and a egr valve. It seems that neither of these would cause a sudden loss of spark.


    enclosed is a pic of eec out of car and what mechanic says car calls for part # he says is written on page
    Attached Images Attached Images   

  6. #6
    Join Date
    Dec 2009
    Location
    Toronto
    Posts
    2,103
    Unfortunately my spare eec is at the shop so I can't confirm codes.

    I think if you got 3 yrs of trouble free starts, that its not the eec per say.

    Paul

Similar Threads

  1. I found this FAQ on the SC
    By Active non member in forum Super Coupe Club of Western Canada
    Replies: 15
    Last Post: 12-21-2013, 02:28 AM
  2. '94 5 speed parts car (car now gone) some great items left
    By Mercury267 in forum Parts for Sale
    Replies: 0
    Last Post: 09-29-2005, 05:48 PM
  3. Got me a 35th 5 speed to restore :)
    By unclenick in forum Super Coupe Club of Florida
    Replies: 18
    Last Post: 07-26-2005, 08:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •