Results 1 to 2 of 2

Thread: Pulling the engine and noticed

  1. #1
    Join Date
    Jul 2002
    Location
    Manchester, NH
    Posts
    2,064

    Pulling the engine and noticed

    something very funny. So I knew the engine mounts were bad but exactly how bad I wasn't sure until tonight. I removed the lower intercooler tube and noticed some very strange impressions or grooves on the underside of the tube. My first reaction was that it was rubbing on the frame. Nope. The ribbed insulator that shields the battery cables was wearing grooves into the IC tube. Now I know aluminum is soft but this ribbed shielding is made of plastic. I am lucky the IC tube didn't wear through the battery cable. It would have been one hell of a light show. LOL
    Last edited by 90sc35thann; 04-24-2012 at 09:50 PM. Reason: spelling

  2. #2
    Join Date
    Apr 2002
    Location
    St. Charles, MO
    Posts
    20,142
    Quote Originally Posted by 90sc35thann View Post
    something very funny. So I knew the engine mounts were bad but exactly how bad I wasn't sure until tonight. I removed the lower intercooler tube and noticed some very strange impressions or grooves on the underside of the tube. My first reaction was that it was rubbing on the frame. Nope. The ribbed insulator that shields the battery cables was wearing grooves into the IC tube. Now I know aluminum is soft but this ribbed shielding is made of plastic. I am lucky the IC tube didn't wear through the battery cable. It would have been one hell of a light show. LOL
    You got lucky..usually the power steering hose rubs a hole through the oil pan first. I can't believe that Ford ever put those gel filled mounts on this car...they are complete garbage.

    David
    91 SC AOD 4.2..2.3 Whipple........10.92 @ 126.70
    93 SC AOD 347 Turbo.................10.04 @ 138.99
    My Garage

Similar Threads

  1. I found this FAQ on the SC
    By Active non member in forum Super Coupe Club of Western Canada
    Replies: 15
    Last Post: 12-21-2013, 02:28 AM
  2. New Engine: Oil Pressure / Oil Weight Used
    By DrFishbone in forum Technical Forum
    Replies: 43
    Last Post: 07-12-2010, 12:03 PM
  3. Engine temp reads at 'RM' in NORM ?
    By 90coug in forum Technical Forum
    Replies: 7
    Last Post: 09-21-2005, 09:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •