Results 1 to 6 of 6

Thread: cruise controll dosent work

  1. #1
    Join Date
    Jan 2013
    Posts
    2

    cruise controll dosent work

    i just bought my first super coupe a 1990 mercury cougar xr7 supercharged. the cruise controll dosent turn on any ideas of what the problem might be

  2. #2
    Join Date
    May 2011
    Posts
    825
    stick or auto?

  3. #3
    Join Date
    Aug 2009
    Location
    Junction City, KS
    Posts
    2,391
    Mine was a mis-adjusted switch on the brake pedal stem under the dash.
    Was adjusted so far out of whack it was reading I was stepping on the brakes so it would not engage the Cruise.
    Re-adjusted and no problem.

  4. #4
    Join Date
    Apr 2010
    Location
    SLO County
    Posts
    358

    Cc

    How about the horn. Is it working. Also the ABS light does it flash a three pause the two, then a long pause and repeat? If so it is a clock spring. Even so i think these can fail just part not in all of the connections. If its not the switch or bad vacuum lines check this part for continuity.
    90 5 speed. Owned since 4-91 it had 12,000 mi. Motor out since '99. I'm gonna fix it, really. Hoping for 450+ HP
    95 auto. owned since 03. Now a Daily driver the motor is in. It continues with electrical gremlins. I think in the PCM harness. Will be a daily driver. Expect 300 to 350 HP

  5. #5
    Join Date
    Jan 2010
    Location
    Bossier City, LA
    Posts
    2,149
    Quote Originally Posted by gr8ghost View Post
    How about the horn. Is it working. Also the ABS light does it flash a three pause the two, then a long pause and repeat? If so it is a clock spring. Even so i think these can fail just part not in all of the connections. If its not the switch or bad vacuum lines check this part for continuity.
    Good advise for a 94-95 SC - but for a 1990, no clock spring.

    They didn't use the clock spring until 1993 or 1994 (I want to say 1994, but there were so many changes in 1993, it may have been rolled in then.)

    Getting back to the OP - time to check the BOO (Brake On/Off) switch (do the brake lights work properly? If so, that's in good shape), the vacuum dump valve (it's the higher one of the two off the brake pedal lever), vacuum lines to the servo (it's in the front fender up by the battery), the linkage to the servo, and if you're unlucky like me, it could be a broken servo or linkage.

    I don't really know of any good way to test the servo and linkage, except by visual.

    In order to make it easier, I would HIGHLY recommend picking up a factory service manual and a EVTM either from the original printers for Ford, Helm Inc ( http://www.helminc.com ) or off eBay. Check the pricing at Helm before you buy on eBay - our manuals tend to the cheap side for new (around $20 or so each), so a "Full manual set only $99.95!", whereas a heck of a deal for my Malibu, would be a rip for the SC *grins*

    RwP

  6. #6
    Join Date
    Apr 2010
    Location
    SLO County
    Posts
    358

    Red face

    Yes I jumped the gun there. I just figured they all had them. Thanks for the info.
    90 5 speed. Owned since 4-91 it had 12,000 mi. Motor out since '99. I'm gonna fix it, really. Hoping for 450+ HP
    95 auto. owned since 03. Now a Daily driver the motor is in. It continues with electrical gremlins. I think in the PCM harness. Will be a daily driver. Expect 300 to 350 HP

Similar Threads

  1. Cruise Control.
    By T1Bird in forum Technical Forum
    Replies: 1
    Last Post: 10-26-2005, 02:58 AM
  2. Northeast Iowa Fall Car Cruise
    By forcfed93 in forum SCCoA Events
    Replies: 1
    Last Post: 09-19-2004, 11:16 PM
  3. Northeast Iowa Car Cruise
    By forcfed93 in forum Super Coupe Club of Iowa
    Replies: 0
    Last Post: 09-04-2004, 01:47 PM
  4. Your help wanted: Links page
    By blkthndr in forum sccoa.com website
    Replies: 1
    Last Post: 07-25-2002, 11:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •