Results 1 to 6 of 6

Thread: 89 sc idle problem

  1. #1
    Join Date
    Jan 2013
    Posts
    7

    89 sc idle problem

    Car idles at 500 rpm consistently, and lacks power when any load is put on the engine.
    Already replaced: IAC, Ignition control module, Spark plugs/wires, coil pack, ALL engine gaskets (intake, head, TB etc.)

    Heres a video:
    http://www.youtube.com/watch?v=3POp5...ature=youtu.be

  2. #2
    Join Date
    May 2002
    Location
    Dallas, TX
    Posts
    5,641
    Check for collapsed motor mounts... and no Im not joking. Id recommend the solid rubber replacements.

  3. #3
    Join Date
    Feb 2004
    Location
    IA
    Posts
    4,252
    245,000 on the clock. When was the last time anything was rebuilt as far as the engine, blower, clutch?
    Honor, Grace and Dignity......Remember these

  4. #4
    Join Date
    Jan 2013
    Posts
    7
    Well, the clutch was just replaced, and we also just replaced the head gaskets after we did the clutch.

  5. #5
    Join Date
    Jan 2013
    Posts
    7
    Quote Originally Posted by TbirdSCFan View Post
    Check for collapsed motor mounts... and no Im not joking. Id recommend the solid rubber replacements.
    The guy who owned it before us had already replaced them to solid engine mounts. And that really isn't the problem anyway.

    Thanks for any advice you can give us. God bless.

  6. #6
    Join Date
    Apr 2002
    Location
    St. Charles, MO
    Posts
    20,889
    Suggest checking the fuel pressure regulator to make sure the vacuum hose that attaches to the return plenum is installed. Without the hose installed fuel pressure will stay constant at around 39 psi instead of increasing pound for pound with boost. You can also do a fuel pressure test by attaching a gauge to the test port on the fuel rail.

    You say it doesn't have any power under a load, but it would help if you were more specific. For example does it bogg and just feel poochy when you step on the gas or does it buck and backfire? Are you getting a check engine light ?

    David
    1991 SC AOD 4.2..2.3 Whipple..........10.910 @ 125.61
    2016 SRT Challenger Hellcat...............707HP/650TQ

    My Garage

Similar Threads

  1. Idle Problem & oil leak
    By heirmb in forum Technical Forum
    Replies: 1
    Last Post: 10-26-2007, 02:12 PM
  2. Idle problem still.
    By 1BADSC in forum Technical Forum
    Replies: 7
    Last Post: 03-22-2003, 12:01 AM
  3. 75mm Pro-M Idle Problem
    By Boostman23 in forum Technical Forum
    Replies: 3
    Last Post: 10-26-2002, 03:31 AM
  4. help!!! idle problem
    By bcr2886 in forum Technical Forum
    Replies: 6
    Last Post: 08-19-2002, 02:57 AM
  5. high idle problem Please HELP
    By Gears in forum Technical Forum
    Replies: 3
    Last Post: 07-16-2002, 11:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •