Page 1 of 2 12 LastLast
Results 1 to 15 of 21

Thread: New to the SC, Purchased a 91 with 58K.

  1. #1
    Join Date
    Oct 2011
    Location
    South Dakota
    Posts
    41

    New to the SC, Purchased a 91 with 58K.

    What's up!? I am also a member at tccoa but i recently sold my 97v8 bird and picked up this beautiful 91SC with 5speed & only 58K. The interior is immaculate and the exterior is great also. It had some engine codes stored tho and i was wondering what they ment.
    Here are the codes
    DTC - 542, 175, 176, 189, 543



  2. #2
    Join Date
    Apr 2007
    Location
    Woodstock Ga
    Posts
    1,772
    Very nice. Good luck!
    How is it compared to drive the V8?
    You are in the right place. Someone will help you with the codes!

  3. #3
    Join Date
    Feb 2013
    Location
    Denver, Colorado
    Posts
    319
    Quote Originally Posted by N8tiveJuggalo17 View Post
    What's up!? I am also a member at tccoa but i recently sold my 97v8 bird and picked up this beautiful 91SC with 5speed & only 58K. The interior is immaculate and the exterior is great also. It had some engine codes stored tho and i was wondering what they ment.
    Here are the codes
    DTC - 542, 175, 176, 189, 543
    Looks good! Try using google, I just searched DTC 542 Ford and it said there's a bad ground. I'd try doing the same for all the other codes and see what you can come up with.


    Steve

  4. #4
    Join Date
    Aug 2012
    Location
    South Dakota, The West Side
    Posts
    83
    Nice SC,

    I live in Rapid City, looks like you took the pic up at the Carmike Ten. Nice to see another SC'er in South Dakota. My SC was bought in much worse condition but it is coming together. Like Steve said search and you will find it.
    89 SC-5 Speed - Build in Progress

    Indecision is the key to flexibility, and I am very flexible.

    The beatings will continue until morale improves.

  5. #5
    Join Date
    Sep 2012
    Location
    Raleigh, North Carolina
    Posts
    590
    From my sunpro scanner book...

    542 fuel pump circuit open connection- electronic control assembly to motor ground
    175 HEGO sensor voltage signal not switching
    176 HEGO sensor voltage signal indicates lean bank 2
    189 HEGO sensor voltage signal not switching indicates lean during part throttle engine operation bank 2
    543 fuel pump circuit open connection - electronic control assembly to battery
    Any idiot can make a Mustang fast...
    It takes a special idiot to make a Thunderbird fast!!!
    89 SC 4.3 stroker 384rwhp 473ftlbs
    Best ET 13.085 Best MPH 106.6... got some work to do!
    2016 V6 M90 Dyno Champ 2016 Mod 1 Runner Up

  6. #6
    Join Date
    Oct 2011
    Location
    South Dakota
    Posts
    41
    Quote Originally Posted by SDCoupe View Post
    Nice SC,

    I live in Rapid City, looks like you took the pic up at the Carmike Ten. Nice to see another SC'er in South Dakota. My SC was bought in much worse condition but it is coming together. Like Steve said search and you will find it.
    Your from rapid? Nice! That picture was actually taken by walmart & golden corral.




    Quote Originally Posted by dthompson View Post
    From my sunpro scanner book...

    542 fuel pump circuit open connection- electronic control assembly to motor ground
    175 HEGO sensor voltage signal not switching
    176 HEGO sensor voltage signal indicates lean bank 2
    189 HEGO sensor voltage signal not switching indicates lean during part throttle engine operation bank 2
    543 fuel pump circuit open connection - electronic control assembly to battery
    176,176 & 189 Should be fixed with some new 02 sensors I assume? How do I address code 542 & 543?

  7. #7
    Join Date
    Sep 2012
    Location
    Raleigh, North Carolina
    Posts
    590
    I cant offer much help on those two codes. Just in general I would check the wiring going into the ECA. maybe even re-seat the connector, check for bad wires and corroded connections. If you can find a wiring diagram you can check continuity through the harness.
    Any idiot can make a Mustang fast...
    It takes a special idiot to make a Thunderbird fast!!!
    89 SC 4.3 stroker 384rwhp 473ftlbs
    Best ET 13.085 Best MPH 106.6... got some work to do!
    2016 V6 M90 Dyno Champ 2016 Mod 1 Runner Up

  8. #8
    Join Date
    May 2011
    Location
    Glendale Heights IL
    Posts
    247
    Jeremy, welcome! I'd start with checking every ground you can find. My main battery ground fell apart when I went to change my d/s motor mount. But I haven't had any issues since I replaced it.

  9. #9
    Join Date
    May 2006
    Location
    Chicago, IL
    Posts
    920
    Just run new ground wire to all existing points with a good automotive electrical wire.

    You can use a ground lug (Like in a circuit breaker box) attached to solid metal somewhere easily accessible.
    3 SC's over a pair of SHO's ...

    Plat O Ribs Full House of SVT!
    SCCoA Member#: 3251

  10. #10
    Join Date
    Oct 2011
    Location
    South Dakota
    Posts
    41
    What gauge wire should I use for the grounds? where are they & how many? lol

  11. #11
    Join Date
    Sep 2010
    Location
    Massapequa Park, NY
    Posts
    547
    Quote Originally Posted by N8tiveJuggalo17 View Post
    What gauge wire should I use for the grounds? where are they & how many? lol
    Your best bet is to get the ford EVM manual, it'll save you a whole bunch of headaches and save you a lot of time and money in the process.

  12. #12
    Join Date
    Sep 2011
    Location
    Las Vegas, NV
    Posts
    68
    Did you find the source of the 542, and 543 code yet? My red '91 has the exact same codes. I checked and only found the engine to body ground strap bad, replaced it and cleaned contact points but even after clearing the codes it comes back. I am curious to know where you find the source. I'll post if I find it.

  13. #13
    Join Date
    Oct 2011
    Location
    South Dakota
    Posts
    41
    Quote Originally Posted by RSC'91 View Post
    Did you find the source of the 542, and 543 code yet? My red '91 has the exact same codes. I checked and only found the engine to body ground strap bad, replaced it and cleaned contact points but even after clearing the codes it comes back. I am curious to know where you find the source. I'll post if I find it.
    I have not found it as of yet, I just ordered a bunch of stuff today for a tune up so after I do that I will see if it clears the codes. I did do the fuel pressure test and it was reading 35psi while idling but only 15psi with KoEo. I have changed the fuel filter since then but havent retested.

  14. #14
    Join Date
    Jul 2013
    Location
    LI, NY
    Posts
    788
    Quote Originally Posted by superdadsc View Post
    Very nice. Good luck!
    How is it compared to drive the V8?
    You are in the right place. Someone will help you with the codes!
    I was wondering the same thing...

    Nice car.

    How is it compared to the V8? Inquiring minds want to know...

  15. #15
    Join Date
    Oct 2011
    Location
    South Dakota
    Posts
    41
    Quote Originally Posted by jjklongisland View Post
    I was wondering the same thing...

    Nice car.

    How is it compared to the V8? Inquiring minds want to know...
    I personally love it, with the manual you could really play in the gears and it makes the car feel a whole lost faster then it probably is, The torque on it is amazing. I do miss the casual cruising of the auto but a car is made to be DRIVEN lol, Even my old v8 bird had the jmod,gear & torque without a tune of course, But I think this one would take it out in a race pretty easily.

Similar Threads

  1. newly purchased sc... some questions
    By qg_pointblank in forum Non Technical Forum
    Replies: 9
    Last Post: 11-16-2009, 12:54 AM
  2. 35th 5 speed for sale 58k miles
    By robs90sc in forum Cars for Sale
    Replies: 7
    Last Post: 04-01-2006, 03:23 PM
  3. 90 sc 58k miles
    By robs90sc in forum Cars for Sale
    Replies: 0
    Last Post: 11-22-2005, 06:29 PM
  4. T5 transmission help needed in a newly purchased Mustang!
    By Digitalchaos in forum Non Technical Forum
    Replies: 2
    Last Post: 08-26-2005, 02:10 PM
  5. Just Purchased
    By scpower in forum New SC Owner Forum
    Replies: 1
    Last Post: 08-14-2005, 11:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •