Results 1 to 8 of 8

Thread: SC in Seattle

  1. #1
    Join Date
    Jul 2014
    Location
    Seattle, WA
    Posts
    37

    SC in Seattle

    Hey everyone, I just purchased a '92 SC with 156k. This isn't my first MN12 ('95 Mark8), but I'm new to Tbirds and superchargers. I love the car, but it sat for a few years before I scooped it up. So now I have things popping up here and there that need attention. I'm hoping this site will help me get on the right path as to tips and tricks and what to watch for. Thanks for your help in advance! Name:  20140718_183331.jpg
Views: 92
Size:  255.6 KBName:  20140718_183520.jpg
Views: 93
Size:  196.0 KBName:  20140718_183615.jpg
Views: 95
Size:  238.1 KBName:  20140718_183606.jpg
Views: 93
Size:  234.4 KBName:  20140718_183251.jpg
Views: 94
Size:  224.3 KB

  2. #2
    Join Date
    Dec 2007
    Location
    Salem, OR
    Posts
    6,340
    Welcome - nice looking SC. You'll find tons of info and help here, so if searching the forums doesn't give you what you need, feel free to ask. Good luck w/your '92.

    Ken
    Portland
    -=-

  3. #3
    Join Date
    Apr 2002
    Location
    Ottawa Canada
    Posts
    1,462
    WHOA, nice clean car looks great!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    One thing I recall about the AOD auto trannies, on the kick down cable by the throttle there is some kind of adjustable gizzmo that needs to be set properly or it causes huge issues on those AOD's. Sorry I cannot expand more on this, I had 5 speeds but I know the guys in the club checked their auto's regularly for this.

    Unless 92's were AODE's I think they were not susceptible to this.

  4. #4
    Join Date
    Apr 2002
    Location
    St. Louis, MO
    Posts
    6,379
    What Les is referring to is the TV cable adjustment, and the 1992s do have an AOD. With the age of the car, I'd check the linkage and make sure it has the updated brass bushing. The original one is made of a type of plastic that gets brittle over time and can break, which can ruin a transmission in a hurry. You should be able to buy the bushing at Ford or likely any transmission shop.

    Mileage doesn't matter for the bushing either. My buddy has a 12,000 original mile 1993 Mustang that the original bushing broke on. Luckily he stopped right away and saved the transmission.
    Kurt K (e-mail)
    SCCoA Member #: 443
    '92 SC AOD -- 11.521s @ 116.748mph, 2.0 AR power
    . . . . . . . . . -- 13.547s @ 101.01 mph, only w/ bolt-ons
    '95 SC 5spd -- All Stock, except 17" Simmons wheels.
    '90 SC 35th Anny 5spd -- 3rd owner, 16k miles
    2 '89 XR7 5spd's -- on their way out, really!

  5. #5
    Join Date
    Apr 2002
    Location
    Ottawa Canada
    Posts
    1,462
    YES!!!!!!!!!!!!!!!!!!!! Thanks Ken "the TV cable"

  6. #6
    Join Date
    Feb 2011
    Posts
    642
    Welcome to the forum.
    That is a very clean looking bird there. Good luck with her.

  7. #7
    Join Date
    Jul 2014
    Location
    Seattle, WA
    Posts
    37
    Thanks for your responses! I'll be sure to check out the bushing for the tv cable; I know the bushing that connects the throttle cable to the throttle plate is gone, so I've had to modify a small plastic washer with a c clip to get me by. This is one of several things that I'm finding throughout the car. Right now my biggest problem is something is causing the abs pump to stay on after the key has been turned off. I must raise the hood and re/disconnect the pump every time I park/start the car to keep the pump from running while the car is off. A couple other weird things lead me to believe there may be a short somewhere in the wiring. Here are the CEL codes that I read off the scanner, they may provide a little insight:

    KOEO- 212 Loss of IDM input to EEC or SPOUT circuit grounded
    214 Cylinder Identification Circuit failure

    KOER- 116 ECT out of self test range .3 - 3.7v
    538 Insufficient RPM change during KOER dynamic response test/operator error

    There is also a problem starting the car when it is warm. Ice cold in the morning, it starts up just fine. But after driving the car for any period, it will take 4-5 tries to get the motor started.

    I'll post some of these questions in more specific forums to see if I can get more hits, too. Thanks for all your help!

  8. #8
    Join Date
    Jun 2002
    Location
    Adrian, Michigan
    Posts
    1,355
    DTC 214 is most probably a bad camshaft position sensor. It's super easy to replace and it may just clear up the 212 DTC also. If it were me I'd try and get a Ford/Motorcraft replacement. The other two codes are probably due to the test not being done at operating temp and insufficient throttle input when the test calls for it.
    SCCoA Member # 490 since 1997
    1995 SC (five speed) 12.8913@105.86
    Best 60' 1.7489

    1994 SC (automatic) 13.4829@100.23mph
    Best 60' 1.8539 On a stock long block with bolt on's
    http://www.sccoa.com/forums/garage.p...ge_view&id=638

Similar Threads

  1. 1990 Black SC for sale in Seattle
    By syphon in forum Cars for Sale
    Replies: 6
    Last Post: 04-01-2005, 02:16 AM
  2. 1990 Black SC for sale in Seattle
    By syphon in forum Cars for Sale
    Replies: 0
    Last Post: 01-26-2005, 03:02 AM
  3. Amazing uber-custom SC at car show in Seattle
    By syphon in forum Non Technical Forum
    Replies: 12
    Last Post: 03-12-2003, 01:33 AM
  4. I just spotted an SC in a "NEW" movie
    By jasonLmarsh in forum Non Technical Forum
    Replies: 22
    Last Post: 05-24-2002, 12:36 PM
  5. SC in Syracuse?
    By Chris89cougar in forum Non Technical Forum
    Replies: 1
    Last Post: 05-18-2002, 10:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •