Results 1 to 9 of 9

Thread: First SC 1995 77k original miles....car cuts out....little help?

  1. #1
    Join Date
    Nov 2014
    Location
    Salem Oregon
    Posts
    5

    First SC 1995 77k original miles....car cuts out....little help?

    Just bought a 1995 SC with 77k original miles....car is super super clean!!!....but here is my symptoms. When I jump on the throttle it's wanting to cut out....bucking almost and sputter....sounds a little popping like. It runs great until I get on it....idle is good...starts good. Just has that lag and aggressive sputter. Also when I powered through it once throttle seem to get stuck almost open with the gas pedal returned to normal.

    Head gaskets were done and head work by shop....car has been sitting 9 months until I bought it out of the open garage I peeked through.

    Any help would be great....I'm an carb v8 guy this is my very first SC...but love it!!
    Attached Images Attached Images      

  2. #2
    Join Date
    Jun 2002
    Location
    Adrian, Michigan
    Posts
    1,352
    Almost always a sign of bad plug wires or bad plugs or both.
    Last edited by Jimmy 2Coupes; 11-12-2014 at 08:27 PM.
    SCCoA Member # 490 since 1997
    1995 SC (five speed) 12.8913@105.86
    Best 60' 1.7489

    1994 SC (automatic) 13.4829@100.23mph
    Best 60' 1.8539 On a stock long block with bolt on's
    http://www.sccoa.com/forums/garage.p...ge_view&id=638

  3. #3
    Join Date
    Jan 2003
    Location
    Lexington, KY
    Posts
    595
    Uh oh....something is probably VERY wrong and you should sell it to me! Just kidding. It's most likely a spark plug or wire problem. Hopefully, the wire is just not seated fully.....they are hard to seat unless you have small hands and strong arms.

  4. #4
    Join Date
    Dec 2008
    Location
    Randleman, NC
    Posts
    299
    i had a dirty MAF do the exact same thing on my car! had oil on it from K&N airfilter~

  5. #5
    Join Date
    Nov 2014
    Location
    Salem Oregon
    Posts
    5

    plug wires n plugs

    Quote Originally Posted by Jimmy 2Coupes View Post
    Almost always a sign of bad plug wires or bad plugs or both.
    Yeah one wire won't seat and they look like they need replaced.....looks like they won't be too easy to replace tho lol

  6. #6
    Join Date
    Nov 2014
    Location
    Salem Oregon
    Posts
    5

    Maf

    Quote Originally Posted by shocar4 View Post
    i had a dirty MAF do the exact same thing on my car! had oil on it from K&N airfilter~
    What did you use to clean it?

  7. #7
    Join Date
    Feb 2013
    Location
    Allentown, PA
    Posts
    208
    The plugs and wires on these cars take forever to change. I changed mine when I had the heads off lol. Good luck with your SC. In time you wil get the SC bug like most of us on here have haha. Also they sell some MAF cleaner at autozone that works pretty well. The company that makes it is CRC and I use it all the time

  8. #8
    Join Date
    Feb 2007
    Location
    louisiana
    Posts
    929
    2nd on the dirty mass airflow sensor,i drove myself crazy changing plugs sensors and everything i could think of, and a cap of rubbing alcohol and a q tip fixed it.That was before i found out you could buy the spray cleaner.

  9. #9
    Join Date
    Nov 2007
    Location
    Robinson, IL
    Posts
    231
    If those ideas don't fix it completely, check inside the throttle body housing for gunk! I had changed plugs and wires and cleaned the MAF 3-4 times bofore looking inside the throttle body.... sprayed carb cleaner in there and wiped a bunch of 'gunk' out of it....runs like a dream now!! Now clean that along with the MAF after re-oiling the K&N filter and all is good!!
    1989 5-speed, silver, with a 'Dark Blue' interior, K&N Cone filter, 2.5" free flow exhaust, aftermarket downpipe. "The rest is stock..... for now!

Similar Threads

  1. Replies: 28
    Last Post: 02-05-2014, 12:54 PM
  2. 91 SC/28,000 original miles
    By deeterman in forum Cars for Sale
    Replies: 4
    Last Post: 02-20-2012, 10:40 AM
  3. 91 SC/28,000 original miles
    By deeterman in forum Cars for Sale
    Replies: 0
    Last Post: 02-19-2012, 08:55 PM
  4. 1991 SC Auto 64k Original Miles Oklahoma--SOLD
    By grateful_carl in forum Cars for Sale
    Replies: 3
    Last Post: 02-02-2008, 03:17 AM
  5. 90 sc auto 24k original miles allentown pa
    By twoblownfords in forum Cars for Sale
    Replies: 12
    Last Post: 11-10-2005, 11:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •