Results 1 to 5 of 5

Thread: Question about aftermarket oil press sending unit install

  1. #1
    Join Date
    Apr 2002
    Location
    Howell, NJ
    Posts
    1,708

    Question about aftermarket oil press sending unit install

    I want to install my new oil pressure gauge. I'd also like to keep the stock gauge hooked up and working as well.

    If I use the tee fitting pictured below, do I also use the stock stalk/ fitting in the other pic?

    I don't see how i would be able to squeeze the two sending units into that tight space unless I use both the stock stalk along with the tee.
    Attached Images Attached Images   

  2. #2
    Join Date
    Sep 2006
    Location
    NE, AR
    Posts
    1,570
    I'm using the OEM stalk and a Tee

  3. #3
    Join Date
    Apr 2002
    Location
    Howell, NJ
    Posts
    1,708
    Quote Originally Posted by bowez View Post
    I'm using the OEM stalk and a Tee
    Great thanks!

  4. #4
    Join Date
    Apr 2002
    Location
    St. Louis, MO
    Posts
    6,541
    I used a brass close nipple, a brass tee and a brass street 90. Mine is offset a bit because I'm using a mechanical gauge and have braided SS hose attached instead of a sending unit.

    Here's a picture from my garage page.
    http://www.sccoa.com/forums/garage_a...ent.php?id=687
    Kurt K (e-mail)
    SCCoA Member #: 443
    '92 SC AOD -- 11.521s @ 116.748mph, 2.0 AR power
    . . . . . . . . . -- 13.547s @ 101.01 mph, only w/ bolt-ons
    '95 SC 5spd -- All Stock, except 17" Simmons wheels.
    '90 SC 35th Anny 5spd -- 3rd owner, 16k miles
    2 '89 XR7 5spd's -- on their way out, really!

  5. #5
    Join Date
    Apr 2002
    Location
    Howell, NJ
    Posts
    1,708
    Quote Originally Posted by Kurt K View Post
    I used a brass close nipple, a brass tee and a brass street 90. Mine is offset a bit because I'm using a mechanical gauge and have braided SS hose attached instead of a sending unit.

    Here's a picture from my garage page.
    http://www.sccoa.com/forums/garage_a...ent.php?id=687
    Thanks Kurt! I actually stumbled on that pic last night while searching. I'd like to fit both the oem sending unit and the new gigantic sending unit that came with the gauge in there. I like the idea of being able to get the warning light on the dash if I should have a serious oil pressure problem...

Similar Threads

  1. Oil pressure sending unit
    By the-big-e in forum Technical Forum
    Replies: 9
    Last Post: 12-22-2004, 05:24 PM
  2. Oil pressure sending unit
    By 77fordman in forum Technical Forum
    Replies: 0
    Last Post: 07-13-2003, 10:02 AM
  3. oil pres.sending unit
    By pete buck in forum Technical Forum
    Replies: 1
    Last Post: 06-09-2003, 12:23 AM
  4. Question about aftermarket stereos
    By SpaceGhost in forum Non Technical Forum
    Replies: 2
    Last Post: 05-13-2003, 10:28 PM
  5. Question about putting in a head unit
    By TbSCbos13 in forum Technical Forum
    Replies: 9
    Last Post: 01-23-2003, 05:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •