Results 1 to 7 of 7

Thread: My 1995 SC work-in-progress

  1. #1
    Join Date
    Dec 2006
    Location
    Houston, TX
    Posts
    19

    My 1995 SC work-in-progress

    Hey guys,

    Picked up a bone stock Pearl White 95 SC automatic to add to the flock. Cars body is great, engine seems strong except for some bad sensors, transmission is what I'm unsure about. When I went to buy the car the mlps was obviously messed up. Car would accelerate forward in neutral, reverse did not work at all. Drive worked and shifted through it's gears normally. I purchased and installed a new mlps(neutral marks aligned) and changed transmission fluid with 12qts of Mercon V.

    Now the transmission works perfectly in Park, Neutral, and reverse but when I put it in drive I have to accelerate to about 3000rpm to get the car moving. Second gear is the same way, when it gets to third it feels like the torque converter locks up and then I'm able to accelerate up to normal speeds. If anyone could offer some insight to what may be going on I would really appreciate it.

    I've pulled the KOEO codes but not sure if I am translating them correctly. Here is a link to the video of my test. https://m.youtube.com/watch?v=3ojqJQceiuk

  2. #2
    Join Date
    Feb 2003
    Location
    Tinton Falls, NJ
    Posts
    1,490
    Are you 100% sure the fluid level is full?

  3. #3
    Join Date
    Dec 2006
    Location
    Houston, TX
    Posts
    19
    Yes, 100% on fluid level. The one code I seem to be getting references the Transmission temperature sensor. Would this have any effect on my issue?

  4. #4
    Join Date
    Feb 2003
    Location
    Tinton Falls, NJ
    Posts
    1,490
    It certainly shouldn't cause the symptoms you are experiencing. If anything, that would send it into failsafe mode and it would default to 2nd gear, but you said it is shifting through the gears, so that rules that out. Does it behave the same regardless of whether the shifter itself is in D, 2, or 1? If it works properly in the manual settings but not in D, then it might be that the shifter itself is misaligned. I have seen that before where D is actually between D and N on the shifter, and if you put it in D, it will want to neutral out, but in those cases, selecting the gear manually made it engage normally.

  5. #5
    Join Date
    Dec 2006
    Location
    Houston, TX
    Posts
    19
    It will manually shift throught the gears but with the same symtoms getting going

  6. #6
    Join Date
    Dec 2006
    Location
    Houston, TX
    Posts
    19
    In the process of swapping to a 99 mustang trans now.

  7. #7
    Join Date
    Dec 2006
    Location
    Houston, TX
    Posts
    19
    She's back on the road running good! Now going through all the miscellaneous crap. Door sagging, endlinks shot, radio not working, etc.

Similar Threads

  1. 1995 SC Automatic in Middle TN: $2500.00
    By dklitzke in forum Cars for Sale
    Replies: 7
    Last Post: 01-21-2008, 03:36 PM
  2. Replies: 2
    Last Post: 07-30-2006, 11:29 PM
  3. my 93 sc dyno in pa
    By twoblownfords in forum Technical Forum
    Replies: 6
    Last Post: 07-04-2005, 11:45 AM
  4. Selling my 94 SC 5spd./ in California.
    By chepdog in forum Super Coupe Club of Northern California
    Replies: 13
    Last Post: 10-26-2003, 10:12 AM
  5. Will the 3.55 gears from my 88 Turbocoupe work in my 89 SC?
    By phils89sc in forum Technical Forum
    Replies: 2
    Last Post: 08-30-2002, 10:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •