Results 1 to 11 of 11

Thread: Just got a 90 and have some questions

  1. #1
    Join Date
    Oct 2015
    Location
    Northern IN
    Posts
    10

    Just got a 90 and have some questions

    So i just picked this up a couple week ago and i love it already, its very clean but has a couple problems.

    I'm pretty sure the valve cover gaskets are leaking, i just ordered a set today. That shouldn't be that hard to replace. The power steering has to be leaking somewhere, it was filled 3 weeks and is starting to get low again. I can hear it when turning.

    Sometimes when i'm at idle it likes to die. It starts dropping RPMs down to about 800 then will come back up for a second or so then back down lower and lower every time. I'm don't really have any idea why it's doing that.

    I couldnt get the pictures to upload so they are here.

  2. #2
    Join Date
    Sep 2015
    Location
    Connecticut
    Posts
    223

    bumper cover

    Rear bumper cover is sick. Is that real or photoshop?

  3. #3
    Join Date
    Dec 2007
    Location
    Salem, OR
    Posts
    6,294
    Quote Originally Posted by chickencoupe View Post
    Rear bumper cover is sick. Is that real or photoshop?
    The inserts are reflective and light up from the camera's flash.

  4. #4
    Join Date
    Oct 2015
    Location
    Northern IN
    Posts
    10
    Nope those are actual lights, they come on with the running lights.
    http://imgur.com/Hqx4tYR

  5. #5
    Join Date
    Dec 2007
    Location
    Salem, OR
    Posts
    6,294
    Quote Originally Posted by Zodiac View Post
    Nope those are actual lights, they come on with the running lights.
    http://imgur.com/Hqx4tYR
    Backlit? I'm impressed!

  6. #6
    Join Date
    Sep 2015
    Location
    Connecticut
    Posts
    223
    Does the front light up as well?

    Sorry I dont have the answer for you question. Mine does the same periodically only after running then shutting off and restart hot. On restart(occasionally) it will kick down to base idle then drop into almost a stall and then float between base and stall untill it finds base and usually smooth out after some rough idle. That is with out manipulating throttle. It hasent stalled yet but compared to how perfectly it starts cold and gradually comes down to idle it has me concerned so if you figure out what it is id be interested to know.
    Last edited by chickencoupe; 11-05-2015 at 05:54 PM.

  7. #7
    Join Date
    Oct 2015
    Location
    Northern IN
    Posts
    10
    Does anyone else have problems like oil coming out of the dipstick? I just replaced the PCV valve in hopes that was the problem, but it wasnt. The oil is coming out the dipstick and going all over the driver side wheel well and then drips down to the headers then smokes... its really annoying

  8. #8
    Join Date
    Sep 2015
    Location
    Connecticut
    Posts
    223

    zodiac are you still on here?

    Hey
    I have some questions regarding how you backlit your rear bumper. You still around?

  9. #9
    Join Date
    Oct 2015
    Location
    Northern IN
    Posts
    10
    I'm kinda still around...
    I have no idea how it works, the previous owner had it up on a lift and couldn't figure it out either

  10. #10
    Join Date
    Sep 2015
    Location
    Connecticut
    Posts
    223
    Well if you ever figure it out it would be cool to know the way it was accomplished.

    Ever figure out your issue with it blowing oil?

  11. #11
    Join Date
    Jun 2002
    Location
    Adrian, Michigan
    Posts
    1,352
    Oil coming out of the dipstick tube can be a sure sign of a substantial amount of blowby.
    SCCoA Member # 490 since 1997
    1995 SC (five speed) 12.8913@105.86
    Best 60' 1.7489

    1994 SC (automatic) 13.4829@100.23mph
    Best 60' 1.8539 On a stock long block with bolt on's
    http://www.sccoa.com/forums/garage.p...ge_view&id=638

Similar Threads

  1. Picked up a 94/95 blower, and have some questions
    By barrieguy in forum Super Coupe Club of Ontario
    Replies: 11
    Last Post: 03-26-2008, 10:12 AM
  2. Replies: 12
    Last Post: 10-03-2004, 08:04 PM
  3. Sup guys have some questions and pics to share
    By ROCSC in forum Super Coupe Club of Ontario
    Replies: 8
    Last Post: 09-17-2003, 07:27 PM
  4. Just got my 90 sc and its dead!
    By FlyingLow90 in forum Technical Forum
    Replies: 1
    Last Post: 06-24-2003, 01:45 PM
  5. just got 73mm MAF and it came with the computer chip but
    By white90sc in forum Technical Forum
    Replies: 3
    Last Post: 12-18-2002, 01:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •