Results 1 to 5 of 5

Thread: Sweet, acetone smell when A.C. is on

  1. #1
    Join Date
    Dec 2015
    Location
    Daytona Beach, FL
    Posts
    181

    Sweet, acetone smell when A.C. is on

    So I'm spending a few days in Tampa right now, but I've been noticing a really strong, sweet-ish smell that smells alot like nail polish remover through my vents when the A.C. is on. It's coming from the front left side of the engine bay near both the A.C. Compressor and Coolant reservoir, and is being sucked in through the AC. I wouldn't think it's Freon since I just replaced basically everything in the A.C. system, and the a.c. still cools. But the smell seems to go away when I turn the a.c. to "vent". I've smelled it before, even before I replaced the A.C., but it's never been this noxious. It doesn't smell like liquid coolant either. I don't think I'm losing coolant, and the car isn't overheating.

    So I thought I'd ask you guys if you have any ideas. Thanks a bunch!!

    Joseph Betros

  2. #2
    Join Date
    Apr 2002
    Location
    Milwaukee, Wisconsin
    Posts
    3,242

    check your anti freeze

    that sweet smell is normally from the anti freeze... check to see if you are going down, also check to see if the floor is wet under the heater....good luck.....Rich
    Too many cars,too little time to drive them. Anything less than 500 cubes is a small block. If you slow down in life you will get run over..

  3. #3
    Join Date
    Dec 2007
    Location
    Salem, OR
    Posts
    6,293
    Do you typically run the A/C on norm or max? I think max, which re-circulates inside air, deals with raised humidity - what you're smelling might be mold in the cabin system.

    Try some lysol spray into the vent funnel under the pass. side wiper cowl, and into the dash vents, then run the A/C on norm (vent) to see if that has any effect. If so, you've found your issue.

  4. #4
    Join Date
    Dec 2015
    Location
    Daytona Beach, FL
    Posts
    181
    Quote Originally Posted by KMT View Post
    Do you typically run the A/C on norm or max? I think max, which re-circulates inside air, deals with raised humidity - what you're smelling might be mold in the cabin system.

    Try some lysol spray into the vent funnel under the pass. side wiper cowl, and into the dash vents, then run the A/C on norm (vent) to see if that has any effect. If so, you've found your issue.
    Ive been forced to run it on max (smells the worst when on norm) when I start smelling the smell, since that usually stops it unless it gets REALLY overpowering. It's not all the time, it usually happens (if it's gonna happen) in the middle of the day when it's like 90 and the car is warmed up after having been driving for at least 15mins. For instance, i drove around today around sunset and I didn't smell a thing. Coolant isn't low, but I did add some extra to the reservoir and marked it, so I'll see if it drops over the next day or two. I'd think it was leftover acetone from when I cleaned my MAF and IAC valve (as well as some other engine parts with brakleen), but it's been at least 4 months since I even touched that engine with any acetone or solvent. It's not freon, the AC was blowing at 55 today when I measured the temp.

  5. #5
    Join Date
    Dec 2007
    Location
    Salem, OR
    Posts
    6,293
    Right, norm brings outside air in via the port under the cowling, so anything external that contributes to any odor on that side of the car is going to come back towards that opening and wind up inside the cabin. I'd expect 4 month old vapors to have dissipated by now, but acetone is strong stuff, so...

    Outside of odors inside the car and that vent outside, nothing is going to be 'sucked in' to the A/C system otherwise.

    As noted, a 'sweet' smell is usually coolant, so do as suggested and check the carpeting and insulation under where the heater core is to see if it's wet.

Similar Threads

  1. When AC is on car gets hot.
    By chadder1313 in forum Technical Forum
    Replies: 3
    Last Post: 08-15-2005, 11:41 PM
  2. Car does not shift when engine is on..5speed
    By DGernmann in forum Technical Forum
    Replies: 17
    Last Post: 10-28-2004, 11:35 PM
  3. Engine revs when a/c is on...m.a.f.?
    By Jslobig in forum Technical Forum
    Replies: 2
    Last Post: 06-29-2004, 08:33 AM
  4. Car smells like exhaust when defroster is on?
    By syphon in forum Technical Forum
    Replies: 12
    Last Post: 04-06-2003, 12:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •