Results 1 to 10 of 10

Thread: Solid ABS light?

  1. #1
    Join Date
    Apr 2003
    Location
    Ventura, CA
    Posts
    1,747

    Solid ABS light?

    My ABS light came on and stayed on today. No flashing. What's the most likely cause? On my Camaro, a solid ABS light can indicate a bad wheel bearing, but not sure about these cars.

  2. #2
    Join Date
    Dec 2007
    Location
    Salem, OR
    Posts
    6,340
    What year?

    See this link for all the details (1989-1992 Thunderbird SC ABS Systems):
    http://www.sccoia.org/articles/anti-...raking-system/


    I think wheel bearings would need to be falling off the car to be involved on an SC, tho
    Last edited by KMT; 08-12-2017 at 10:46 AM.

  3. #3
    Join Date
    May 2002
    Location
    Dallas, TX
    Posts
    5,648
    Quote Originally Posted by Mercutio View Post
    My ABS light came on and stayed on today. No flashing. What's the most likely cause?
    Check to see the pump has stopped running. If the light is on, and the pump continues to run, then it isnt making peak pressure. Usually indicates a very small leak, often around the accumulator, and/or steel high pressure line. Often at the fittings.

    If the light is on, and the pump is off, then there is another issue. Try to pull codes and also inspect the sensor wiring. Some people have had problems with the ABS computer in the trunk tray. If you have a spare, it might be worth a swap out to see if the problem persists. Third thing is there is a relay on the firewall on the passenger side, that controls power to the ABS module. If thats bad, it can trip the yellow light as well.

  4. #4
    Join Date
    May 2012
    Location
    Oregon
    Posts
    768
    I've always wondered - how does one determine if the pump is running? Is the pump the device under the driver side front fender??? Do you simply feel it?

  5. #5
    Join Date
    May 2002
    Location
    Dallas, TX
    Posts
    5,648
    Quote Originally Posted by potshotscott View Post
    I've always wondered - how does one determine if the pump is running? Is the pump the device under the driver side front fender??? Do you simply feel it?
    The pump is right beneath the brake fluid reservoir on the firewall. You may have to open the hood and get close to hear it running. Its also easier if the engine is off. You often don't need the engine running to test if the pump is building enough pressure... but the constant "ding-ding-ding" from the warning chime might drown it out... thats why many of us unplugged that thing long ago

  6. #6
    Join Date
    Apr 2002
    Location
    Norcross, GA
    Posts
    3,304
    I've found that the most common problems are, the antilock relay, the pump brushes, or the high pressure switch. Check Duffy Floyd's article on how to jumper the pump. It is a round connector on the fender side of the reservoir. I'd replace the relay first since it is easiest. The pump and switch are a bear to R & R.
    90 5spd, best ever E.T. 12.250
    best ever 1/4mi speed 112.89 mph
    Current dyno tune 383.54 rwhp 418.88 rwt

  7. #7
    Join Date
    Sep 2004
    Location
    Herrin Illinois
    Posts
    3,385
    Quote Originally Posted by potshotscott View Post
    I've always wondered - how does one determine if the pump is running? Is the pump the device under the driver side front fender??? Do you simply feel it?
    if the pump is running you will hear it also if its not the brake pedal will be hard
    MEMBER #2488 best rwhp 504 485 torque
    2016 shootout Best of show award
    2015 Carlisle Best of show modified, 1st place 92 93 SC and Celebrity's choice award winner.
    2014 Shootout Best of show 1st award winner
    2014 Comp cams VIP Car craft street machine nationals
    http://www.sccoa.com/forums/garage.p...e_view&id=7152

  8. #8
    Join Date
    Feb 2016
    Location
    Cincinnati, OH
    Posts
    135
    Quote Originally Posted by Mike Puckett View Post
    I've found that the most common problems are, the antilock relay, the pump brushes, or the high pressure switch.
    If you need any of these, I have some.

  9. #9
    Join Date
    Jun 2002
    Location
    ny\long island
    Posts
    2,657

    93 Sc abs

    I'm having problems on my 93 Sc.amber light came on, checked the fuse and it was blown.put another fuse and that blew asoon as I put it in.so for some reasons its grounding out, my search begins.

  10. #10
    Join Date
    Sep 2004
    Location
    Herrin Illinois
    Posts
    3,385
    my solid abs light was low fluid
    MEMBER #2488 best rwhp 504 485 torque
    2016 shootout Best of show award
    2015 Carlisle Best of show modified, 1st place 92 93 SC and Celebrity's choice award winner.
    2014 Shootout Best of show 1st award winner
    2014 Comp cams VIP Car craft street machine nationals
    http://www.sccoa.com/forums/garage.p...e_view&id=7152

Similar Threads

  1. ABS light on solid, brake light not on
    By Ripper in forum Technical Forum
    Replies: 6
    Last Post: 01-03-2004, 01:38 AM
  2. about the brake and abs light
    By AnvSCMAN in forum Technical Forum
    Replies: 3
    Last Post: 11-17-2002, 05:17 PM
  3. Rear end thunk..ABS light ...
    By tbirdsc35th in forum Technical Forum
    Replies: 6
    Last Post: 09-13-2002, 07:49 PM
  4. blinking abs light....
    By HappyHourHero in forum Technical Forum
    Replies: 4
    Last Post: 07-21-2002, 03:35 PM
  5. Traction Control & ABS light problems
    By tbirdsc357 in forum Super Coupe Club of Ontario
    Replies: 1
    Last Post: 07-11-2002, 12:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •