Results 1 to 4 of 4

Thread: Did you lose the heat/blower motor?

  1. #1
    Join Date
    Jul 2005
    Location
    Palos Heights
    Posts
    2,291

    Did you lose the heat/blower motor?

    Ok....if you find yourself suddenly faced with no heat/blower operation........checking the usual higher amp fuses is a must...........still nothing? Ok.........in Ford's infinite wisdom..they tired about 11 circuits to one fuse. Check the 5 Amp fuse in your fuse panel. If it's blown.that maybe the source of all your problems. Ask me cuz' I know..........my 94' SC did that to me.

  2. #2
    Join Date
    Jan 2010
    Location
    Bossier City, LA
    Posts
    2,151
    No, I knew exactly where it was. It did blow the fuse and quit, though *grins*

    RwP

  3. #3
    Join Date
    Jul 2005
    Location
    Palos Heights
    Posts
    2,291

    heat

    All the damn wires, fuses......and Ford used a 5 amp fuse..........and call it RUN on the panel.......who decided on that?....LOL.............works fine now.

  4. #4
    Join Date
    Jan 2010
    Location
    Bossier City, LA
    Posts
    2,151
    Quote Originally Posted by CougarXR/7 View Post
    All the damn wires, fuses......and Ford used a 5 amp fuse..........and call it RUN on the panel.......who decided on that?....LOL.............works fine now.
    Well, it's only running the EATC, and it's only when you're in RUN, so ...

    (It's the "We're on and running" and is more a control voltage than a real voltage; that way, there's less current on that one wire.)

    RwP

Similar Threads

  1. hey!! when did you get the AR installed on your SC!!!
    By automaniak22 in forum Technical Forum
    Replies: 2
    Last Post: 04-10-2010, 08:20 AM
  2. How much boost did you lose?....
    By CMac89 in forum Non Technical Forum
    Replies: 4
    Last Post: 11-15-2005, 11:10 PM
  3. SEN REG15 did you get the baffle?
    By mannysc in forum Non Technical Forum
    Replies: 1
    Last Post: 09-11-2002, 08:04 PM
  4. hey, what did you have to do to mod the fan
    By sc steve in forum Technical Forum
    Replies: 1
    Last Post: 07-10-2002, 12:12 PM
  5. Did you see the news, was that a white Sc that died today?
    By la cougar racha in forum Super Coupe Club of Northern California
    Replies: 1
    Last Post: 06-22-2001, 02:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •