Results 1 to 5 of 5

Thread: Just bought a 90' SC, having boost related problems

Hybrid View

  1. #1
    Join Date
    Sep 2017
    Posts
    2

    Exclamation Just bought a 90' SC, having boost related problems

    when under load, at like 35 mph in 3rd and I try to accelerate the rpms stay at like 1500 and it goes into boost and knocks, still without accelerating. Any ideas on what could cause this?

  2. #2
    Join Date
    May 2012
    Location
    Oregon
    Posts
    759
    There are many things that will do this so not trying to make you "lock on" to one thing but it's either some sort of cam/crank sensor timing issue or you have a wasted harmonic balancer that's messing with things. It's a gutless wonder under boost no? How high does the temperature gauge go?

  3. #3
    Join Date
    Apr 2002
    Location
    Madison, Ohio
    Posts
    17,532
    That or might be clogged cats/exhaust.
    Quote Originally Posted by Miller View Post
    Ya thats why i tape mine down. People think its bc i dont have a moonroof seal (which is true) but its really to keep my roof from ripping off .
    Email me here.

  4. #4
    Join Date
    Sep 2017
    Posts
    2
    Quote Originally Posted by potshotscott View Post
    There are many things that will do this so not trying to make you "lock on" to one thing but it's either some sort of cam/crank sensor timing issue or you have a wasted harmonic balancer that's messing with things. It's a gutless wonder under boost no? How high does the temperature gauge go?
    I'm thinking its a sensor cause the check engine light is also on and I'm picking up a scanner tomorrow. And the temp gauge reads just above half

  5. #5
    Join Date
    Oct 2005
    Location
    Southwest of Kansas City
    Posts
    2,264
    One of my SC's did this and it ended up being a cracked spark plug.
    Jim, SCCoA Member#: 2789

    "cuz Jim has mad skillz, yo!" Melon.
    "You guys crack me up talking about nitrous when you don't even know if you can keep it together on gasoline." XR7 Dave
    "I didn't break it, I found it's weakness."

Similar Threads

  1. Just bought a 90 SC w/39k miles
    By kostaccio in forum New SC Owner Forum
    Replies: 15
    Last Post: 12-14-2012, 05:03 PM
  2. Replies: 12
    Last Post: 10-03-2004, 08:04 PM
  3. So I finally bought a '90 SC Off another board member
    By syphon in forum New SC Owner Forum
    Replies: 3
    Last Post: 09-14-2002, 04:27 AM
  4. I just bought my old sc back!!!!!!!!!!!!
    By SCSteve in forum Non Technical Forum
    Replies: 9
    Last Post: 05-16-2002, 01:03 AM
  5. Just bought a 92 SC with 84k on her
    By wwwtbirdforumcom in forum New SC Owner Forum
    Replies: 1
    Last Post: 05-15-2002, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •