Results 1 to 10 of 10

Thread: 1995 5-speed runs fine, many extras

Threaded View

  1. #1
    Join Date
    Sep 2017
    Posts
    6

    1995 5-speed runs fine, many extras

    Anyone interested in a '95 5-speed before I offload it elsewhere? It runs fine, but idle takes a bit to kick down for some reason (vacuum leak?) I ran out of time and need to move. Engine still very strong.

    Extras:
    SCP 3" Fresh Air Intake, C&L 73mm MAFS with sampling tube for stock injectors, set of larger injectors with matching sampling tube (not installed), 75mm throttle body, screamin' demon coil pack, LiveWires plug wires, Magnum Powers big bore throat SC intake, SCP 3" hi-flow exhaust, headers, new battery, new motor mounts, B&M Ripper short throw shifter, SPEC stage 1 high performance clutch & rebuilt transmission.

    I have the original intake/MAFS/throttle body/SC intake

    Interior is pretty decent... carpet is great, leather has a couple of obligatory leather seam issues.
    Paint is showing it's age.

    $2500 in Annapolis, MD
    Attached Images Attached Images      

Similar Threads

  1. Replies: 9
    Last Post: 05-31-2013, 04:47 PM
  2. 95 5-speed running like crap...
    By 91BLOWNSC in forum Technical Forum
    Replies: 21
    Last Post: 09-27-2004, 07:50 PM
  3. Runs Fine, CEL On, Code 185
    By aviationstation in forum Technical Forum
    Replies: 2
    Last Post: 09-07-2004, 11:53 PM
  4. Running fine one second; High idle the next
    By tbirdboy in forum Technical Forum
    Replies: 1
    Last Post: 04-22-2004, 09:57 PM
  5. Got it running, now many codes
    By Lewis in forum Technical Forum
    Replies: 1
    Last Post: 08-06-2002, 10:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •