Results 1 to 8 of 8

Thread: instrument/gauge lights

  1. #1
    Join Date
    Aug 2004
    Location
    Latitude: 41.909147 Longitude: -72.450263
    Posts
    2,022

    instrument/gauge lights

    Just recently my instrument/gauge lights started acting up. Only around where the gauges are. Then the came back on. Today on the way home nothing. Weird how they came back on and now nothing. Tomorrow who knows . I won't be able to do any troubleshooting until this weekend.


    Don't crash into a tree just to avoid a skunk!


  2. #2
    Join Date
    Dec 2007
    Location
    Salem, OR
    Posts
    6,340
    I had a similar issue once...turned out last time I R & R'd the cluster I didn't fully seat one of the large wire harness connectors. Confirm they are square to the pocket and the retaining clips are firmly seated. Might not hurt to have the cluster out of the way so you can swab some connector grease on the terminals as part of the process.

    Still no joy, check the multi-wire ignition switch down on the side of the steering column. Replace it depending on age. Still no joy, find another cluster to test with so you can see if that's the issue.

  3. #3
    Join Date
    Jan 2010
    Location
    Bossier City, LA
    Posts
    2,156
    In between KMT's two steps, be sure to remove/reinstall the twist lock sockets; you may have oxidation under the contacts also.

    RwP

  4. #4
    Join Date
    Apr 2002
    Location
    Greenville, IN
    Posts
    4,256
    Don't forget to check the ignition switch....

    Instrument lights could be the least of your worries.
    Matt Haub
    Shootouts: '09 SS 1st | '10 Mod1 2nd | '11 Bracket 3rd | '12 Bracket 1st | 2013 | '14 Bracket 3rd | 2015 | '16 Bracket 1st & Mod2 2nd | 2017 |
    Black '89 5spd - 281K miles, MPx, E85, Alky-Inj RWHP: ? RWTQ: ? Best 1/4mi:12.521, MPH:107.23mph
    35th Anniversary Auto 46k miles | Red '93 Auto 186k miles
    My Garage

  5. #5
    Join Date
    Dec 2007
    Location
    Salem, OR
    Posts
    6,340
    Quote Originally Posted by DrFishbone View Post
    Don't forget to check the ignition switch....

    Glad you agreed - thanks for the confirmation.

    Ken

  6. #6
    Join Date
    Dec 2007
    Location
    Salem, OR
    Posts
    6,340
    Quote Originally Posted by RalphP View Post
    In between KMT's two steps, be sure to remove/reinstall the twist lock sockets; you may have oxidation under the contacts also.

    RwP
    Good tip, thanks for adding. Include a bit of bulb/connector grease as part of that process and live large

  7. #7
    Join Date
    Jun 2002
    Location
    SCCoA Member#1257
    Posts
    3,278
    If you are replacing new bulbs (which I recommend, since you're there) make sure you get good quality ones. I ordered some bulk bulbs from the interwebs and two of them ended up acting up after I put the cluster back together. Eventually one started working correctly but currently I still cant see the green arrow when turning left on the teal car .

    Will be fixing the speedo gear in the chameleon during the winter and I was going to ask for brand recommendations for good bulbs.
    Current: 1993 SC 5.0L Auto Red, 1994 SC 5-speed Teal, 1995 SC 5-speed Chameleon Blue
    Old: 89 SC auto Twilight Blue, 89 SC stick Titanium, 90 35th stick, 92 Sport 5.0L stick, 94 SC stick Black, 1994 SC Auto Teal
    Also: 1992 Feature Mustang Convertible 5-speed Vibrant Red, 1991 BMW 850i 6-speed Red, 1994 BMW 850CSi 6-speed Red

    www.mamn12.com for your mid-atlantic mn12 needs!

  8. #8
    Join Date
    Dec 2007
    Location
    Salem, OR
    Posts
    6,340
    Quote Originally Posted by CaifanSC View Post
    I was going to ask for brand recommendations for good bulbs.
    I've had better luck scrounging used OE bulbs over new...

Similar Threads

  1. Gauge lighting went out!!! HELP
    By klsoneSC in forum Technical Forum
    Replies: 15
    Last Post: 03-18-2004, 02:10 PM
  2. "Check Gauge" Light?
    By Gregthespy in forum Technical Forum
    Replies: 7
    Last Post: 12-19-2002, 04:01 AM
  3. check gauge light comes on when.
    By sabre81 in forum Technical Forum
    Replies: 7
    Last Post: 10-16-2002, 05:47 PM
  4. Check Gauge light when cranking.
    By matt89sc in forum Technical Forum
    Replies: 2
    Last Post: 07-30-2002, 06:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •