Page 6 of 6 FirstFirst ... 23456
Results 76 to 82 of 82

Thread: 2018 HRPT June 9-15

  1. #76
    Join Date
    Jul 2002
    Location
    Roanoke, Virginia
    Posts
    3,258
    Sounds good, were loading up now. Smitty and his Dad took the official route and left earlier. We're going the fastest way which tells us 12 noon arrival.

    See ya in a few.

    -Tim
    Current Collection
    1994 Thunderbird SC - Auto converted to 5spd

    1995 Thunderbird SC - Auto

    1994 Thunderbird SC - 5spd
    1989 Thunderbird SC - 5spd - Daily Driver
    1990 Thunder/Cougar XR7 - 5spd
    1994 Thunderbird SC - 3v Project

  2. #77
    Join Date
    Apr 2002
    Location
    St. Louis, MO
    Posts
    6,425
    $10 for two laps would have been awesome. I hope they do that in the future. Years ago, I was able to take a lap around the oval at Gateway on the way to the 2nd World Ford Challenge. We were supposed to stay under 50 mph....I managed to see 100+ before catching up to the group. This was before GoPro cameras, but I do have a picture somewhere that I took as I entered the track.
    Kurt K (e-mail)
    SCCoA Member #: 443
    '92 SC AOD -- 11.521s @ 116.748mph, 2.0 AR power
    . . . . . . . . . -- 13.547s @ 101.01 mph, only w/ bolt-ons
    '95 SC 5spd -- All Stock, except 17" Simmons wheels.
    '90 SC 35th Anny 5spd -- 3rd owner, 16k miles
    2 '89 XR7 5spd's -- on their way out, really!

  3. #78
    Join Date
    Jun 2009
    Location
    Charlotte, NC
    Posts
    250
    Great day at Darlington today.

    Thanks for your help guys! See ya Friday.

    I'll post some pix tomorrow.

  4. #79
    Join Date
    Apr 2002
    Location
    St. Charles, MO
    Posts
    20,939
    This sounds a lot like the HRPT with me, Kurt K., Tony S. & Chris W. Have fun guys !!

    David
    1991 SC AOD 4.2..2.3 Whipple..........10.910 @ 125.61
    2016 SRT Challenger Hellcat...............707HP/650TQ

    My Garage

  5. #80
    Join Date
    Jun 2009
    Location
    Charlotte, NC
    Posts
    250
    Tried uploading and attaching some photos - with FF and IE. But it doesn't appear to be working. Could someone check my account settings. Any suggestions? Thanks.

  6. #81
    Join Date
    Dec 2007
    Location
    PNW
    Posts
    6,544
    Quote Originally Posted by Trunk Monkey View Post
    Any suggestions?.
    Seems borked for all of us since the last upgrade...need to wait it out, I guess.

  7. #82
    Join Date
    Jun 2009
    Location
    Charlotte, NC
    Posts
    250
    Ok. Thanks. At least I know I'm not the only one having this issue.

Similar Threads

  1. 2012 HRPT - Miami, OK (Stop #5) June 6
    By Kurt K in forum SCCoA Events
    Replies: 2
    Last Post: 06-07-2012, 09:09 AM
  2. Replies: 9
    Last Post: 06-06-2012, 04:49 AM
  3. 2012 HRPT - Muskegon, MI (Stop #2) June 3
    By Kurt K in forum SCCoA Events
    Replies: 2
    Last Post: 06-03-2012, 07:44 PM
  4. 2012 HRPT - Detroit (Stop #1) June 1&2
    By Kurt K in forum SCCoA Events
    Replies: 1
    Last Post: 06-03-2012, 06:31 AM
  5. 2012 HRPT - Champaign, IL (Stop #3) June 4
    By Kurt K in forum SCCoA Events
    Replies: 2
    Last Post: 05-15-2012, 10:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •