Results 1 to 5 of 5

Thread: Instrument Cluster Lighting

  1. #1
    Join Date
    Jan 2003
    Location
    Lexington, KY
    Posts
    598

    Instrument Cluster Lighting

    Ladies and Gents!

    Woah it's been a long time since posting (probably), but I didn't see much (current) on the way of possibly going to LED's in the instrument cluster. It looks like replacing the bulb (Ford Manual part number 13466) with LED's "194" will work? There's some talk back in 2012 about making sure there's a resistor on it, but I'm not sure. I have one bulb out and want to replace it, but haven't been to the auto parts stores yet. Not really looking forward to pulling the climate control and doing the same thing soon. Anybody got any info?

  2. #2
    Join Date
    Nov 2016
    Location
    PNW
    Posts
    289
    Here is SuperBrightLEDS 194's on a bench cluster. They come with a resistor. The amp dash light should be left (new) factory style 194. Need to add another to take care of the dim starting at 60 or so.
    Creighton
    Attached Images Attached Images  

  3. #3
    Join Date
    Jan 2003
    Location
    Lexington, KY
    Posts
    598
    That looks pretty good! You said it comes with a resistor...is it built in? Or do you have to jerry rig up something? And you need to add another 194 bulb to help dim at 60 watts? Sorry, I'm a little confused.

  4. #4
    Join Date
    Dec 2002
    Location
    Fayetteville, Ar
    Posts
    1,219
    Quote Originally Posted by Michael Mattix View Post
    That looks pretty good! You said it comes with a resistor...is it built in? Or do you have to jerry rig up something? And you need to add another 194 bulb to help dim at 60 watts? Sorry, I'm a little confused.
    He needs to add another bulb because it's dimming beginning at around 60 MPH on his speedo as you should be able to see in the pic.

  5. #5
    Join Date
    Nov 2016
    Location
    PNW
    Posts
    289
    Thanks! Resistor built in. Direct plug to the factory dash sockets.
    Regret confusion. Needs another bulb to better light the 80-120 mph. part of the gauge. Soon to be be Km blacked out 145 mph:-).

    Current/Amp/heat draw and generated is far less serious with LED's. Attached photo of one in the factory connector. Let me know if need any other information.

    Next up will be blacked needles with just red tips. Hate extra light at night.
    Creighton
    Attached Images Attached Images  
    Last edited by Creighton; 02-13-2018 at 01:50 AM. Reason: errors omissions.

Similar Threads

  1. Aftermarket Instrument Cluster for 89 TBird
    By C5 Corvette in forum Technical Forum
    Replies: 1
    Last Post: 08-05-2003, 06:48 PM
  2. Pics of my custom instrument cluster
    By cary Jackson in forum Non Technical Forum
    Replies: 8
    Last Post: 05-26-2003, 02:10 PM
  3. Instrument Cluster not working
    By 1BADBYRD in forum Technical Forum
    Replies: 0
    Last Post: 03-11-2003, 08:56 PM
  4. Instrument cluster transfer?
    By joshbea6 in forum Technical Forum
    Replies: 1
    Last Post: 10-07-2002, 02:34 PM
  5. cleaning instrument cluster cover
    By Steve Richards in forum Non Technical Forum
    Replies: 5
    Last Post: 06-28-2002, 07:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •