Results 1 to 4 of 4

Thread: Cooling fan problems on 95 SC

  1. #1
    Join Date
    Jun 2018
    Location
    Rapid City South Dakota
    Posts
    5

    Cooling fan problems on 95 SC

    My buddy has a 95 SC that seems to be having strange problems for his highspeed pull fan. If the car sits and idles only the low speed fan will kick on and the car's temperature will continue to climb non stop. If you give the car just a little bit of throttle input the high speed fan will then kick on. We adjusted the idle screw a little bit and the fan then kicked on a bit but then the car would idle at 1200 or so at times. It seems that it has to be above 1000 rpm for the fan to be running for some reason.

    He already replaced the fan relays, the fan motor, the ect sensor because of the car trying to overheat at stoplights but when driving down the road its fine. Yesterday is when we noticed the fan only coming on with increased idle. What could cause this?

  2. #2
    Join Date
    Dec 2007
    Location
    PNW
    Posts
    6,538
    Do all the fans/speeds self-test ok? Any codes?

  3. #3
    Join Date
    Jun 2018
    Location
    Rapid City South Dakota
    Posts
    5
    The fans test ok it just needs an increased idle to stay on. The push fan runs constantly just the pull fan will not come on. No codes that I am aware of.

  4. #4
    Join Date
    Jul 2005
    Posts
    405
    Good evening


    I would do the following:


    Check the condenser fins. Bent fins will be a cause of insufficient airflow to the radiator. A radiator comb is required.

    https://www.youtube.com/watch?v=olMJEAnEBvo


    Check the isolation foam between the condenser and radiator for serviceability.


    Do a coolant pressure test.


    https://www.youtube.com/watch?v=K5p-G3UDi-A


    If the above are OK remove the radiator and take it to a pro radiator repair shop to have it checked out.




    https://www.youtube.com/watch?v=yb03DB97vas

Similar Threads

  1. Low Coolant Sensor Problem on '95 SC
    By ezgoing in forum Technical Forum
    Replies: 2
    Last Post: 03-10-2004, 06:58 PM
  2. Cooling fan quit on me
    By derekhay316 in forum Technical Forum
    Replies: 8
    Last Post: 08-22-2003, 06:14 AM
  3. Engine Cooling Fan Problem?
    By studpike in forum Technical Forum
    Replies: 7
    Last Post: 05-07-2003, 03:25 AM
  4. ?'s about EEC Tuners or Chips on 95 SC
    By Robert Kohlman in forum Technical Forum
    Replies: 5
    Last Post: 04-16-2003, 02:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •