Results 1 to 3 of 3

Thread: DTC 217 Primary ignition coil failure coil#3

  1. #1
    Join Date
    Jun 2011
    Location
    San Diego
    Posts
    409

    DTC 217 Primary ignition coil failure coil#3

    More super coupe life problems. I think I’m chasing a short. So before i started trying to get my AC going I got a drivability issue Lost of power at startup Rough idle wide band would go dead lean. It would do it while cold and occasionally while warm. Pulled codes and 217 keeps popping up if I clear and experience the issue. I swapped in a BorgWarner nice new piece and works great for 3 days now I get the same drivability same code. The old coil pack showed black crusty stuff and the inside bottom of coil 3 so I figured it was a justified replacement. I eyeballed the harness and it looked ok. I plan removing the harness and going through it completely but any other ideas? Also Alternator went out. I think the tint shop might’ve hooked up a booster wrong. I replaced with a used one from my shed and cleaned al my battery connections and grounds and solenoid contacts. Starts up better so there’s that!
    Last edited by figulaz; 07-10-2018 at 05:23 PM.
    --L.Figueroa

  2. #2
    Join Date
    Dec 2010
    Location
    Zephyrhills F.L.
    Posts
    174
    The coil grounds to the coil mount then to the bracket holding the coil, alternator, and power steering pump, then the bracket transfers the ground to the block, be sure all mounting points are clean to ensure good grounds for all.
    Last edited by fstcoup; 07-10-2018 at 06:08 PM.

  3. #3
    Join Date
    Jun 2011
    Location
    San Diego
    Posts
    409
    So I got lazy and decided to throw a ICM this morning at the problem instead of actual diagnostic work and it drove fine for about 5 mins and the I got the 211 pip code. It kind a bucked and wanted to shut off at higher rpms which was different than the loss off power when I got the 217 code. The ICM I changed was the Wells F135 boxed by Autozone duralast for $60. This part number is for an 89 SC. The 93 SC calls for Wells F147 which was $160.from what Iíve read these are backwards compatible. Has anyone had a similar experience fixed by using correct ICM? Its intermittent. I checked the crankshaft pulley with the belt off...Bolt is there and no wobble Cam sensor was replaced about 1 year ago and I have tach signal but it gets a little erratic when fault manifests itself. I kind donít mind the throwing some parts at it as these senors may be upto 25 yrs old for all I know
    --L.Figueroa

Similar Threads

  1. Ignition module or coil failure?
    By OffRoadRanger00 in forum Technical Forum
    Replies: 3
    Last Post: 10-16-2014, 09:51 PM
  2. code 217 DIS fault ignition system coil #3
    By LikeNew92 in forum Technical Forum
    Replies: 13
    Last Post: 08-03-2007, 03:34 PM
  3. need knew coil pack and ignition module.
    By shultzy321 in forum Technical Forum
    Replies: 4
    Last Post: 09-23-2004, 11:12 AM
  4. Coil/ignition/PCM help please
    By Steve Richards in forum Super Coupe Club of Ontario
    Replies: 18
    Last Post: 08-31-2002, 12:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •