Page 6 of 6 FirstFirst ... 23456
Results 76 to 86 of 86

Thread: 2018 SC Shootout Shuffle?

  1. #76
    Join Date
    Aug 2005
    Location
    Paoli Indiana
    Posts
    4,695
    Classic sign of dis failure just buy a new one it's an antique
    93 SC Red Auto 111k
    2013 Shootout Bracket ET First Place
    2015 Shootout Car Show Honerable Mention
    2016 Shootout Mod-1 First Place
    4.2, 2.3 Whipple, 3.73s AOD
    422rwhp 11.360 /??? mph
    90 SC 35th auto 84k

  2. #77
    Join Date
    Aug 2004
    Location
    KSRQ
    Posts
    5,202
    Quote Originally Posted by Jacob_Royer View Post
    Classic sign of dis failure just buy a new one it's an antique
    Yea, ordered one online today since there isn't a place around here that has one in stock. Should be here Monday. I guess we'll see.

  3. #78
    Join Date
    Apr 2002
    Location
    Greenville, IN
    Posts
    4,418
    Ira - Sorry you didn't make it - missed seeing you and several others this past weekend.

    David N - so you were still having meth problems, right? After swapping controllers? What does the AFR do around the time it starts cutting out? Narrowband sensor readings would probably be more helpful. I wonder if your pump is just worn out?

    Chris - very nice SUV you guys have! I saw your brother on Friday night (dark) and wondered why you looked so different than I remembered! lol So...Sara won some SC parts....is that a sign?! Super cute little guy you all have too.

    David C - missed you too man...the banter is alot more fun when everyone is there.

    Jacob - you seemed as worn out as I felt yesterday...made some good passes though! need to figure out what was up with the nitrous though....I'm pretty sure that system wasn't working right in some way.

    Me - I spent all weekend SHUFLN...finally called it quits after blowing the 4th freeze plug since the new motor. Based on how / when / what temperatures they have happened, I'm not worried about combustion gas in the coolant passages....just need to pull the motor and replace them all at once, before one of the bad ones blow! I made 387rwhp at like 5500rpm with a maxed-out MAF, overly-rich tune, 22deg timing, hot engine, and freeze plug ending the pull early! lol Excited to see what a little more timing and alot more RPM has in store. Looks like the blower is still keeping up at 6000+....should be solid combo! Also pulled a 12.75 @ 111mph 1/4mi.....with a 2.0s 60' and granny shift or two....gotta re-adjust my launch apparently...felt like the slicks spun off the line for 20ft....still had about 19psi in them though. Freeze plug blew on that pass too - at the end of the track, we're thinking. Coolant was like 95/5 distilled water / antifreeze at least. Anyway - the new longblock is alot of fun as long as the water stays inside!
    Last edited by DrFishbone; 10-01-2018 at 01:39 PM.
    Matt Haub
    Shootouts: '09 SS 1st | '10 Mod1 2nd | '11 Bracket 3rd | '12 Bracket 1st | 2013 | '14 Bracket 3rd | 2015 | '16 Bracket 1st & Mod2 2nd | 2017 |
    Black '89 5spd - 281K miles, MPx, E85, Alky-Inj RWHP: ? RWTQ: ? Best 1/4mi:12.521, MPH:107.23mph
    35th Anniversary Auto 46k miles | Red '93 Auto 186k miles
    My Garage

  4. #79
    Join Date
    Aug 2005
    Location
    Paoli Indiana
    Posts
    4,695
    Best I could tell it was never spraying any nitrous at all only fuel.


    Quote Originally Posted by DrFishbone View Post
    Ira - Sorry you didn't make it - missed seeing you and several others this past weekend.

    David N - so you were still having meth problems, right? After swapping controllers? What does the AFR do around the time it starts cutting out? Narrowband sensor readings would probably be more helpful. I wonder if your pump is just worn out?

    Chris - very nice SUV you guys have! I saw your brother on Friday night (dark) and wondered why you looked so different than I remembered! lol So...Sara won some SC parts....is that a sign?! Super cute little guy you all have too.

    David C - missed you too man...the banter is alot more fun when everyone is there.

    Jacob - you seemed as worn out as I felt yesterday...made some good passes though! need to figure out what was up with the nitrous though....I'm pretty sure that system wasn't working right in some way.

    Me - I spent all weekend SHUFLN...finally called it quits after blowing the 4th freeze plug since the new motor. Based on how / when / what temperatures they have happened, I'm not worried about combustion gas in the coolant passages....just need to pull the motor and replace them all at once, before one of the bad ones blow! I made 387rwhp at like 5500rpm with a maxed-out MAF, overly-rich tune, 22deg timing, hot engine, and freeze plug ending the pull early! lol Excited to see what a little more timing and alot more RPM has in store. Looks like the blower is still keeping up at 6000+....should be solid combo! Also pulled a 12.75 @ 111mph 1/4mi.....with a 2.0s 60' and granny shift or two....gotta re-adjust my launch apparently...felt like the slicks spun off the line for 20ft....still had about 19psi in them though. Freeze plug blew on that pass too - at the end of the track, we're thinking. Coolant was like 95/5 distilled water / antifreeze at least. Anyway - the new longblock is alot of fun as long as the water stays inside!
    93 SC Red Auto 111k
    2013 Shootout Bracket ET First Place
    2015 Shootout Car Show Honerable Mention
    2016 Shootout Mod-1 First Place
    4.2, 2.3 Whipple, 3.73s AOD
    422rwhp 11.360 /??? mph
    90 SC 35th auto 84k

  5. #80
    Join Date
    Jul 2005
    Location
    Clarksville, TN
    Posts
    1,828
    Quote Originally Posted by Jacob_Royer View Post
    Best I could tell it was never spraying any nitrous at all only fuel.
    Yep lesson learned there, bottle pressure means nothing, must have some extra weight besides the bottle weight.

    I will be getting a small bathroom scale for future events so I don't run into this issue.

    Good to see you guys again! Stayed tuned to a new thread for Trans tear down pics and updates!
    Venetian Blue 1995 5 Spd...............No ET
    Orange Crush Pearl 1995 Auto SC........TBD
    506.30 rwhp, 545.37tq
    Garage:http://www.sccoa.com/forums/garage_v..._vehicle&id=13

  6. #81
    Join Date
    Apr 2002
    Location
    St. Charles, MO
    Posts
    21,015
    Quote Originally Posted by DrFishbone View Post
    Ira - Sorry you didn't make it - missed seeing you and several others this past weekend.

    David N - so you were still having meth problems, right? After swapping controllers? What does the AFR do around the time it starts cutting out? Narrowband sensor readings would probably be more helpful. I wonder if your pump is just worn out?

    Chris - very nice SUV you guys have! I saw your brother on Friday night (dark) and wondered why you looked so different than I remembered! lol So...Sara won some SC parts....is that a sign?! Super cute little guy you all have too.

    David C - missed you too man...the banter is alot more fun when everyone is there.

    Jacob - you seemed as worn out as I felt yesterday...made some good passes though! need to figure out what was up with the nitrous though....I'm pretty sure that system wasn't working right in some way.

    Me - I spent all weekend SHUFLN...finally called it quits after blowing the 4th freeze plug since the new motor. Based on how / when / what temperatures they have happened, I'm not worried about combustion gas in the coolant passages....just need to pull the motor and replace them all at once, before one of the bad ones blow! I made 387rwhp at like 5500rpm with a maxed-out MAF, overly-rich tune, 22deg timing, hot engine, and freeze plug ending the pull early! lol Excited to see what a little more timing and alot more RPM has in store. Looks like the blower is still keeping up at 6000+....should be solid combo! Also pulled a 12.75 @ 111mph 1/4mi.....with a 2.0s 60' and granny shift or two....gotta re-adjust my launch apparently...felt like the slicks spun off the line for 20ft....still had about 19psi in them though. Freeze plug blew on that pass too - at the end of the track, we're thinking. Coolant was like 95/5 distilled water / antifreeze at least. Anyway - the new longblock is alot of fun as long as the water stays inside!
    Matt,

    I'm pretty certain that it's an ignition problem. Ran good for one or two rips down the test road across from hotel and made one clean pull on the dyno after putting on another set of plug wires donated by Jacob, but still couldn't use the methanol or it would misfire. Data logging showed 11.7 AFR with methanol off, and when missing starts it turns the logs into a jumbled mess. Even with methanol off at the track it was missing at higher rpms and was really missing bad with meth on, so it never ran better than 11.3 @ 119. It got progressively slower as temps increased because I'm sure it was pulling timing without the methanol on.

    Yesterday I ordered a new Motorcraft coil pack, new Livewires plug wires, and a set of NGK 7317 plugs. Fingers crossed that fixes it.

    David
    1991 SC AOD 4.2..2.3 Whipple..........10.910 @ 125.61
    2016 SRT Challenger Hellcat.............10.597 @ 135.78

    My Garage

  7. #82
    Join Date
    Aug 2005
    Location
    Paoli Indiana
    Posts
    4,695
    The looms that fit the Taylor's will not fit the livewires properly so i recomend bills looms.

    Quote Originally Posted by David Neibert View Post
    Matt,

    I'm pretty certain that it's an ignition problem. Ran good for one or two rips down the test road across from hotel and made one clean pull on the dyno after putting on another set of plug wires donated by Jacob, but still couldn't use the methanol or it would misfire. Data logging showed 11.7 AFR with methanol off, and when missing starts it turns the logs into a jumbled mess. Even with methanol off at the track it was missing at higher rpms and was really missing bad with meth on, so it never ran better than 11.3 @ 119. It got progressively slower as temps increased because I'm sure it was pulling timing without the methanol on.

    Yesterday I ordered a new Motorcraft coil pack, new Livewires plug wires, and a set of NGK 7317 plugs. Fingers crossed that fixes it.

    David
    93 SC Red Auto 111k
    2013 Shootout Bracket ET First Place
    2015 Shootout Car Show Honerable Mention
    2016 Shootout Mod-1 First Place
    4.2, 2.3 Whipple, 3.73s AOD
    422rwhp 11.360 /??? mph
    90 SC 35th auto 84k

  8. #83
    Join Date
    Apr 2002
    Location
    Greenville, IN
    Posts
    4,418
    Quote Originally Posted by David Neibert View Post
    Matt,

    I'm pretty certain that it's an ignition problem. Ran good for one or two rips down the test road across from hotel and made one clean pull on the dyno after putting on another set of plug wires donated by Jacob, but still couldn't use the methanol or it would misfire. Data logging showed 11.7 AFR with methanol off, and when missing starts it turns the logs into a jumbled mess. Even with methanol off at the track it was missing at higher rpms and was really missing bad with meth on, so it never ran better than 11.3 @ 119. It got progressively slower as temps increased because I'm sure it was pulling timing without the methanol on.

    Yesterday I ordered a new Motorcraft coil pack, new Livewires plug wires, and a set of NGK 7317 plugs. Fingers crossed that fixes it.

    David
    Yeah...it has to be an iginition problem....exacerbated by the meth injection - not caused by.
    Matt Haub
    Shootouts: '09 SS 1st | '10 Mod1 2nd | '11 Bracket 3rd | '12 Bracket 1st | 2013 | '14 Bracket 3rd | 2015 | '16 Bracket 1st & Mod2 2nd | 2017 |
    Black '89 5spd - 281K miles, MPx, E85, Alky-Inj RWHP: ? RWTQ: ? Best 1/4mi:12.521, MPH:107.23mph
    35th Anniversary Auto 46k miles | Red '93 Auto 186k miles
    My Garage

  9. #84
    Join Date
    Apr 2002
    Location
    St. Charles, MO
    Posts
    21,015
    Quote Originally Posted by Jacob_Royer View Post
    The looms that fit the Taylor's will not fit the livewires properly so i recomend bills looms.
    Yes, I ordered the billet looms from Bill too.
    1991 SC AOD 4.2..2.3 Whipple..........10.910 @ 125.61
    2016 SRT Challenger Hellcat.............10.597 @ 135.78

    My Garage

  10. #85
    Join Date
    Apr 2002
    Location
    St. Charles, MO
    Posts
    21,015
    Quote Originally Posted by DrFishbone View Post
    Yeah...it has to be an iginition problem....exacerbated by the meth injection - not caused by.
    I'm thinking the same, but not 100% certain the stuff I'm changing will fix it because everything was already changed. Just not at the same time and not always with brand new stuff. BTW, If your wondering what a new Motorcraft coil pack sells for it was about $135 plus tax from the local Ford dealer.

    David
    1991 SC AOD 4.2..2.3 Whipple..........10.910 @ 125.61
    2016 SRT Challenger Hellcat.............10.597 @ 135.78

    My Garage

  11. #86
    Join Date
    Sep 2004
    Location
    Herrin Illinois
    Posts
    3,426
    Well the shuffle stopped me from making the shootout for the first time and I finally got the surge tank leak proofed about an hour ago after pulling it 4 or 5 times for more welding. The bumper is still in the body shop but I was able to make the intercooler modification I have been wanting to make for a couple of years through all of this. Also the car is running on e85 for the first time although a havnt been able to drive it yet lol.Name:  20180928_164357.jpg
Views: 78
Size:  4.36 MB
    Name:  20180928_164427.jpg
Views: 75
Size:  4.31 MB
    Name:  20181003_165747.jpg
Views: 70
Size:  2.88 MB
    member #2488
    2016 shootout Best of show award
    2015 Carlisle Best of show modified, 1st place 92 93 SC and Celebrity's choice award winner.
    2014 Shootout Best of show 1st award winner
    2014 Comp cams VIP Car craft street machine nationals
    http://www.sccoa.com/forums/garage.p...e_view&id=7152

Similar Threads

  1. 2018 SC Shootout registration is open!
    By Pat DiPersia in forum Super Coupe Shootout
    Replies: 34
    Last Post: 09-13-2018, 06:57 PM
  2. SC Shootout - Match Race!
    By XR7 Dave in forum SCCoA Events
    Replies: 106
    Last Post: 08-30-2003, 01:29 AM
  3. Important SC Shootout info PLEASE READ
    By Wzenheimer in forum SCCoA Events
    Replies: 2
    Last Post: 08-11-2003, 03:28 PM
  4. Sc Shootout Update 6-6-03
    By Wzenheimer in forum SCCoA Events
    Replies: 21
    Last Post: 08-03-2003, 02:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •