Results 1 to 3 of 3

Thread: New Headlight still have problem?

  1. #1

    Question New Headlight still have problem?

    I have bought a pair of new led headlight bulbs, but after I have installed them on, my car start to hyper flash. It also causes my front turn signals to barely work. Do I install them in a wrong way? I've test the bulbs which can work normally with my bulb tester. How can these happen?

  2. #2
    Join Date
    Dec 2007
    Location
    Pacific Rim
    Posts
    6,722
    What year is your SC?

    Did you ask auxbeam about it? They would know best, I think.

    My guess is you need to add resistors. Maybe something like this: https://www.amazon.com/Lifetime-LED-.../dp/B01N99X1EV

  3. #3
    Quote Originally Posted by KMT View Post
    What year is your SC?

    Did you ask auxbeam about it? They would know best, I think.

    My guess is you need to add resistors. Maybe something like this: https://www.amazon.com/Lifetime-LED-.../dp/B01N99X1EV
    They have replied me. I gussed it was the bulb problem, but find out it is the resistor. Thank you.

Similar Threads

  1. Still having problems with my 90 SC
    By ddwood55 in forum Technical Forum
    Replies: 3
    Last Post: 03-26-2008, 08:56 AM
  2. Still having problems with passive restraint?
    By Joe90SC in forum Technical Forum
    Replies: 2
    Last Post: 12-18-2004, 08:04 PM
  3. Still having problems
    By 35th T-bird SC in forum Technical Forum
    Replies: 13
    Last Post: 03-18-2004, 06:51 AM
  4. Still having problems.....
    By SLP007 in forum Technical Forum
    Replies: 1
    Last Post: 02-27-2004, 09:50 PM
  5. New or Still Old Problem
    By T1Bird in forum Super Coupe Club of Ontario
    Replies: 30
    Last Post: 06-30-2003, 10:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •