Page 3 of 7 FirstFirst 1234567 LastLast
Results 31 to 45 of 104

Thread: Possibly bad tps need some help

  1. #31
    Join Date
    May 2018
    Location
    Irmo SC
    Posts
    111
    No egr wires at o2s look good possibly replaced not long before I got it I'm ordering a ObdI scanner to ensure that I pull codes correctly as soon as I have it I'll definitely pull codes

  2. #32
    Join Date
    May 2018
    Location
    Irmo SC
    Posts
    111
    Those vacuum lines that are plugged connected to a tree of other vacumm lines so unless washer fluid goes through the vacumm system the lines shouldn't be for washers and they don't work but I belive that's tied to the under the column issues the pump doesn't come on the blinkers don't function and only 1 speed for wiper motor I think that multiswitch is either bad or possibly wrong one all together bacause the only way to stop the 1 speed on wipers is to set the switch to high.... I know it's a mess trying to work through years of terrible mechanics from the previous owners every time I do something I'm scratching my head and saying why would you think this was a good idea lol

  3. #33
    Join Date
    Dec 2007
    Location
    Salem OR
    Posts
    7,302
    FYI, anything I might suggest assumes a (nearly) stock setup. If you're running a chip, cam, etc. etc. all bets are off.

    Those vacuum lines puzzle me, but for now I'm just going to ignore them.

  4. #34
    Join Date
    May 2018
    Location
    Irmo SC
    Posts
    111
    Mostly stock only a BBK 3.73 rear gear everything else is stock

  5. #35
    Join Date
    Dec 2007
    Location
    Salem OR
    Posts
    7,302
    Got it, thanks.

    The more we go over things, like the WOT CEL, the less I trust the TPS on your BBK. Once you pull codes, we might re-visit it, and as much as I'm normally against it in this example, get creative.

    Any chance you have the stock throttle body?

  6. #36
    Join Date
    May 2018
    Location
    Irmo SC
    Posts
    111
    No I don't have the stock one the bbk was already on it when I got the car

  7. #37
    Join Date
    May 2018
    Location
    Irmo SC
    Posts
    111
    BTW I sincerely appreciate the time you are spending to help me out with this I really do appreciate it

  8. #38
    Join Date
    Dec 2007
    Location
    Salem OR
    Posts
    7,302


    No problem - you're a hero for even taking on the job w/this one, I think, so anything I can do to help, even if it just means having someone to bounce ideas off of.

    And like I said, I have a few things in mind, but I'll wait for codes so I do my best to not send you goose chasing. Not a deal breaker if that doesn't happen, but what with so many geese, well, you know.

    BTW, I've come out retirement for the next several weeks, and may not be as free to reply here, but I won't be offline entirely.

    Ken

  9. #39
    Join Date
    May 2018
    Location
    Irmo SC
    Posts
    111

    Angry

    Few more things I've discovered. The tensioner for the J. S. to SC is not holding enough pressure making me wonder if the belt is slipping under heavy load and causing studder and cel momentarily. So I've got one ordered and will install soon and found more spliced wires behind the cover next to your left foot in driver's seat all seem to be lock and window related but certainly not supposed to be that way so more things to redue yay me

  10. #40
    Join Date
    May 2018
    Location
    Irmo SC
    Posts
    111
    Also I pulled the bolts out of the 2 lines that are plugged with the engine running there doesn't seem to be any vacumm on them so possibly they are washer lines that are somehow divided inside that vacuum tree?

  11. #41
    Join Date
    May 2018
    Location
    Irmo SC
    Posts
    111

    Engine codes

    Finally got an Obd1 scan tool codes are. 67,87,10,41,49,53,87,95,96 so the fuel circuit codes are certainly because the fuel pump is straight wired because of electrical issues in the dash I've tried to put a relay in it and it won't turn the pump on. The clutch switch is bypassed meaning you don't have to depress the clutch to start the car I got an o2 code so I guess I'll be putting o2s in it a tps code not sure what route to take with that and mostly curious about the spout signal code not even sure what that means any and all help would be appreciated

  12. #42
    Join Date
    Dec 2007
    Location
    Salem OR
    Posts
    7,302
    Let's ignore these, at least for now:

    • 67 O Neutral Drive Switch circuit open
    • 87 O,C Primary Fuel Pump circuit failure
    • 10 - separator code
    • 87 O,C Primary Fuel Pump circuit failure
    • 95 O,C Fuel Pump circuit open, ECA to motor
    • 96 O,C Fuel Pump circuit open, battery to ECA

    ...and focus on these:
    41 R,C Oxygen sensor circuit indicates system lean, right side
    49 C Default spark error (3.8L SC only)
    53 O,C Throttle Position Sensor (TPS) out of range (high)

    Normally you want to work first thing on the list, then down, and the 49 alone makes me nervous, but all three together might be a root issue, and not individual problems. Root issue being wiring/grounds.

    49 - electronic distributorless ignition system (EDIS)- spark advance word (SAW) signal error or, spart output (SPOUT) signal changed ignition timing to 10 degrees BTDC (before top dead center) or, transaxle problem 1-2 shift error.

    I recall that you had to replace the balancer and crank sensor. Tell me about the wiring harness, starting at the multi-wire connector at the front pass. side of the supercharger top that goes to the DIS (and SPOUT connector, does it have it's shorting plug), then splits down the front to the cam and crank sensors and over to the coil. Are those in good shape? Are they damaged, mangled, repaired, oil soaked etc. Remind me if you replaced the DIS. Pictures would be great.

  13. #43
    Join Date
    May 2018
    Location
    Irmo SC
    Posts
    111
    Have not replaced dis. Wiring is in decent shape not oil soaked but the clips on the larger plug are broken off but seems to be plugged in fully and not moving I'll take pics asap at work today (on call locksmith) so not home at the moment

  14. #44
    Join Date
    May 2018
    Location
    Irmo SC
    Posts
    111

    Pictures of wiring

    These are the pictures of dis and cps
    Attached Images Attached Images      

  15. #45
    Join Date
    May 2018
    Location
    Irmo SC
    Posts
    111
    Last one that I took if you need more by all means let me know
    Attached Images Attached Images   

Similar Threads

  1. Possibly a new SC owner, need some help making up my mind
    By Steve-O in forum New SC Owner Forum
    Replies: 7
    Last Post: 10-29-2006, 08:30 PM
  2. Need Some Help Guys!
    By SickWhip in forum Super Coupe Club of Ontario
    Replies: 2
    Last Post: 03-14-2006, 10:00 AM
  3. not a sc ?..but need some help
    By tbirdsc22 in forum Non Technical Forum
    Replies: 1
    Last Post: 05-07-2002, 04:08 PM
  4. need some help guys
    By intercooled 89xr7 in forum Super Coupe Club of New Jersey
    Replies: 3
    Last Post: 04-02-2002, 10:39 PM
  5. Need some help
    By blkmojo in forum Super Coupe Club of Northern California
    Replies: 1
    Last Post: 10-01-2001, 06:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •